aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorChristian Persch <chpe@cvs.gnome.org>2006-10-09 03:02:52 +0800
committerChristian Persch <chpe@src.gnome.org>2006-10-09 03:02:52 +0800
commitba138ec9e01ef7c7fb3b583c4babd24cfa5cd69e (patch)
treefb43afb50fb6060c6d7cb88e23c0d08bf0cd615f /src/Makefile.am
parente9340cbe3cecbb19bce27b500b7015e9912452e4 (diff)
downloadgsoc2013-epiphany-ba138ec9e01ef7c7fb3b583c4babd24cfa5cd69e.tar
gsoc2013-epiphany-ba138ec9e01ef7c7fb3b583c4babd24cfa5cd69e.tar.gz
gsoc2013-epiphany-ba138ec9e01ef7c7fb3b583c4babd24cfa5cd69e.tar.bz2
gsoc2013-epiphany-ba138ec9e01ef7c7fb3b583c4babd24cfa5cd69e.tar.lz
gsoc2013-epiphany-ba138ec9e01ef7c7fb3b583c4babd24cfa5cd69e.tar.xz
gsoc2013-epiphany-ba138ec9e01ef7c7fb3b583c4babd24cfa5cd69e.tar.zst
gsoc2013-epiphany-ba138ec9e01ef7c7fb3b583c4babd24cfa5cd69e.zip
Fix a bug in the last commit.
2006-10-08 Christian Persch <chpe@cvs.gnome.org> * embed/Makefile.am: * lib/Makefile.am: * lib/egg/Makefile.am: * src/Makefile.am: * src/bookmarks/Makefile.am: Fix a bug in the last commit.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index c8c3aff3c..03bbeb39f 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -270,7 +270,7 @@ stamp-ephy-type-builtins.c: $(INST_H_FILES) $(NOINST_H_FILES)
--vhead "GType\n@enum_name@_get_type (void)\n{\n" \
--vhead " static GType type = 0;\n\n" \
--vhead " if (G_UNLIKELY (type == 0))\n {\n" \
- --vhead " const G@Type@Value _@enum_name@_values[] = {" \
+ --vhead " static const G@Type@Value _@enum_name@_values[] = {" \
--vprod " { @VALUENAME@, \"@VALUENAME@\", \"@valuenick@\" }," \
--vtail " { 0, NULL, NULL }\n };\n\n" \
--vtail " type = g_@type@_register_static (\"@EnumName@\", _@enum_name@_values);\n }\n\n" \