aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorCarlos Garcia Campos <cgarcia@igalia.com>2013-03-29 00:06:47 +0800
committerCarlos Garcia Campos <carlosgc@gnome.org>2013-04-05 21:47:37 +0800
commita2181b928e5a0f6d27487859fe86a276c1eed25c (patch)
tree9a4915e37cb5f7f75ff686c8936bc34b47ea481c /src/Makefile.am
parentefccc1eac4ac4e15fd4f5695d27a85c7d25c3cc6 (diff)
downloadgsoc2013-epiphany-a2181b928e5a0f6d27487859fe86a276c1eed25c.tar
gsoc2013-epiphany-a2181b928e5a0f6d27487859fe86a276c1eed25c.tar.gz
gsoc2013-epiphany-a2181b928e5a0f6d27487859fe86a276c1eed25c.tar.bz2
gsoc2013-epiphany-a2181b928e5a0f6d27487859fe86a276c1eed25c.tar.lz
gsoc2013-epiphany-a2181b928e5a0f6d27487859fe86a276c1eed25c.tar.xz
gsoc2013-epiphany-a2181b928e5a0f6d27487859fe86a276c1eed25c.tar.zst
gsoc2013-epiphany-a2181b928e5a0f6d27487859fe86a276c1eed25c.zip
Compile template pages as GResources
So that they are loaded from memory instead of disk every time they are needed. We also get rid of ephy_file searching for the files in the file system. https://bugzilla.gnome.org/show_bug.cgi?id=696792
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am11
1 files changed, 7 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 290ca0fb0..b7e6448ad 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -8,7 +8,7 @@ bin_PROGRAMS = epiphany
EXTRA_DIST = \
epiphany.gresource.xml \
- $(UI_FILES) \
+ $(RESOURCE_FILES) \
$(NULL)
NOINST_H_FILES = \
@@ -98,7 +98,7 @@ libephymain_la_CFLAGS = \
$(CODE_COVERAGE_CFLAGS) \
$(AM_CFLAGS)
-UI_FILES = \
+RESOURCE_FILES = \
resources/epiphany-bookmark-editor-ui.xml \
resources/epiphany-history-window-ui.xml \
resources/epiphany-ui.xml \
@@ -106,12 +106,15 @@ UI_FILES = \
resources/epiphany-application-menu.ui \
resources/prefs-dialog.ui \
resources/epiphany.css \
+ resources/error.html \
+ resources/process-crash.html \
+ resources/recovery.html \
$(NULL)
-epiphany-resources.c: epiphany.gresource.xml $(UI_FILES)
+epiphany-resources.c: epiphany.gresource.xml $(RESOURCE_FILES)
$(AM_V_GEN)glib-compile-resources --target=$@ --sourcedir=$(srcdir)/resources --generate-source --c-name epiphany $(srcdir)/epiphany.gresource.xml
-epiphany-resources.h: epiphany.gresource.xml $(UI_FILES)
+epiphany-resources.h: epiphany.gresource.xml $(RESOURCE_FILES)
$(AM_V_GEN)glib-compile-resources --target=$@ --sourcedir=$(srcdir)/resources --generate-header --c-name epiphany $(srcdir)/epiphany.gresource.xml
EPIPHANY_RESOURCES = \