aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMarco Pesenti Gritti <marco@it.gnome.org>2003-07-13 16:52:36 +0800
committerMarco Pesenti Gritti <mpeseng@src.gnome.org>2003-07-13 16:52:36 +0800
commit9f70e82e7fd4d8888f55c63cf3eb911d27b0fbec (patch)
tree089536612813c5504f5fe5a35184e3ff23a8adcd /src/Makefile.am
parentf73556913d8a794f6c8ed17a7664d0a2f61635da (diff)
downloadgsoc2013-epiphany-9f70e82e7fd4d8888f55c63cf3eb911d27b0fbec.tar
gsoc2013-epiphany-9f70e82e7fd4d8888f55c63cf3eb911d27b0fbec.tar.gz
gsoc2013-epiphany-9f70e82e7fd4d8888f55c63cf3eb911d27b0fbec.tar.bz2
gsoc2013-epiphany-9f70e82e7fd4d8888f55c63cf3eb911d27b0fbec.tar.lz
gsoc2013-epiphany-9f70e82e7fd4d8888f55c63cf3eb911d27b0fbec.tar.xz
gsoc2013-epiphany-9f70e82e7fd4d8888f55c63cf3eb911d27b0fbec.tar.zst
gsoc2013-epiphany-9f70e82e7fd4d8888f55c63cf3eb911d27b0fbec.zip
2003-07-13 Marco Pesenti Gritti <marco@it.gnome.org>
* Makefile.am: * configure.in: * embed/Makefile.am: * embed/ephy-embed-shell.c: (ephy_embed_shell_get_favicon_cache), (impl_get_downloader_view): * embed/ephy-embed-shell.h: * embed/ephy-embed-single.c: * embed/ephy-embed-single.h: * embed/mozilla/ProgressListener.cpp: * embed/mozilla/mozilla-embed.cpp: * lib/Makefile.am: * lib/ephy-langs.h: * lib/ephy-node.c: (unref_signal_objects), (ephy_node_signal_connect_object): * plugins/Makefile.am: * plugins/sample/Makefile.am: * plugins/sample/sample.c: (bmk_added), (bmk_removed), (bmk_changed), (switch_page_cb), (window_focus_in_cb), (location_changed_cb), (tab_added_cb), (new_window_cb), (plugin_init): * src/Makefile.am: * src/bookmarks/Makefile.am: * src/bookmarks/ephy-bookmark-action.c: (ephy_bookmark_action_sync_icon): * src/bookmarks/ephy-bookmark-properties.c: (set_window_icon), (ephy_bookmark_properties_init): * src/bookmarks/ephy-bookmarks-editor.c: (provide_favicon), (ephy_bookmarks_editor_init): * src/bookmarks/ephy-bookmarks.c: (update_favorites_menus): * src/bookmarks/ephy-topic-action.c: (build_bookmarks_menu): * src/ephy-automation.c: (impl_ephy_automation_loadurl), (impl_ephy_automation_quit), (impl_ephy_automation_load_session): * src/ephy-favicon-action.c: (ephy_favicon_action_init): * src/ephy-history-window.c: (confirmation_dialog_response_cb), (provide_favicon): * src/ephy-location-action.c: (connect_proxy): * src/ephy-notebook.c: (sync_icon): * src/ephy-shell.c: (ephy_shell_get_active_window), (ephy_shell_get_session), (ephy_shell_get_autocompletion), (ephy_shell_get_toolbars_model): * src/ephy-shell.h: * src/ephy-tab.c: (ephy_tab_net_state_cb), (ephy_tab_init), (ephy_tab_get_action): * src/ephy-tab.h: * src/ephy-tabs-menu.c: (ephy_tabs_menu_update): * src/ephy-window.c: (ephy_window_fullscreen), (ephy_window_unfullscreen), (sync_tab_icon), (ephy_window_init), (remove_from_session), (ephy_window_get_active_tab):
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am56
1 files changed, 33 insertions, 23 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 53cb7c4c7..e47c8331b 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -41,60 +41,70 @@ else
nautilus_view_sources =
endif
+headerdir = $(prefix)/include/epiphany-@EPIPHANY_MAJOR@/epiphany
+header_DATA = $(INST_H_FILES)
+
+NO_INST_H_FILES = \
+ ephy-automation.h \
+ ephy-encoding-menu.h \
+ ephy-favicon-action.h \
+ ephy-favorites-menu.h \
+ ephy-go-action.h \
+ ephy-history-window.h \
+ ephy-location-action.h \
+ ephy-navigation-action.h \
+ ephy-plugin.h \
+ ephy-spinner-action.h \
+ ephy-tabs-menu.h \
+ ephy-toolbars-model.h \
+ language-editor.h \
+ pdm-dialog.h \
+ prefs-dialog.h \
+ ppview-toolbar.h \
+ statusbar.h \
+ toolbar.h \
+ window-commands.h
+
+INST_H_FILES = \
+ ephy-notebook.h \
+ ephy-shell.h \
+ ephy-tab.h \
+ ephy-window.h \
+ session.h
+
epiphany_bin_SOURCES = \
$(ephy_automation_interface_idl_sources) \
$(nautilus_view_sources) \
ephy-automation.c \
- ephy-automation.h \
ephy-encoding-menu.c \
- ephy-encoding-menu.h \
ephy-favicon-action.c \
- ephy-favicon-action.h \
ephy-favorites-menu.c \
- ephy-favorites-menu.h \
ephy-go-action.c \
- ephy-go-action.h \
ephy-history-window.c \
- ephy-history-window.h \
ephy-location-action.c \
- ephy-location-action.h \
ephy-main.c \
ephy-navigation-action.c \
- ephy-navigation-action.h \
ephy-notebook.c \
- ephy-notebook.h \
ephy-plugin.c \
- ephy-plugin.h \
ephy-shell.c \
- ephy-shell.h \
ephy-spinner-action.c \
- ephy-spinner-action.h \
ephy-tab.c \
ephy-tab.h \
ephy-tabs-menu.c \
- ephy-tabs-menu.h \
ephy-toolbars-model.c \
ephy-toolbars-model.h \
ephy-window.c \
- ephy-window.h \
language-editor.c \
- language-editor.h \
pdm-dialog.c \
- pdm-dialog.h \
popup-commands.c \
- popup-commands.h \
prefs-dialog.c \
- prefs-dialog.h \
ppview-toolbar.c \
- ppview-toolbar.h \
session.c \
- session.h \
statusbar.c \
- statusbar.h \
toolbar.c \
- toolbar.h \
window-commands.c \
- window-commands.h
+ $(INST_H_FILES) \
+ $(NOINST_H_FILES)
epiphany_bin_LDADD = \
$(top_builddir)/embed/libephyembed.la \