aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorXan Lopez <xan@igalia.com>2012-01-17 03:11:40 +0800
committerXan Lopez <xan@igalia.com>2012-01-17 03:11:40 +0800
commit52cdd6df6cb561a48032358b3eedce16cfa2c9fb (patch)
tree1170c07244b9a2fba83251880900f8894887ae27 /src/Makefile.am
parent1150405cc1bc50d6c258cb723a76ae90d8945f73 (diff)
downloadgsoc2013-epiphany-52cdd6df6cb561a48032358b3eedce16cfa2c9fb.tar
gsoc2013-epiphany-52cdd6df6cb561a48032358b3eedce16cfa2c9fb.tar.gz
gsoc2013-epiphany-52cdd6df6cb561a48032358b3eedce16cfa2c9fb.tar.bz2
gsoc2013-epiphany-52cdd6df6cb561a48032358b3eedce16cfa2c9fb.tar.lz
gsoc2013-epiphany-52cdd6df6cb561a48032358b3eedce16cfa2c9fb.tar.xz
gsoc2013-epiphany-52cdd6df6cb561a48032358b3eedce16cfa2c9fb.tar.zst
gsoc2013-epiphany-52cdd6df6cb561a48032358b3eedce16cfa2c9fb.zip
Refactor GtkActions with attached EphyWindows
Make a GtkAction subclass that only holds an EphyWindow and nothing else, and use it throughout. Allows us to kill some duplicated code.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index f89a0219f..24d47ae7d 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -25,11 +25,11 @@ NOINST_H_FILES = \
ephy-link-action.h \
ephy-lockdown.h \
ephy-location-action.h \
- ephy-navigation-action.h \
ephy-navigation-history-action.h \
ephy-page-menu-action.h \
ephy-password-info.h \
ephy-toolbar.h \
+ ephy-window-action.h \
languages.h \
pdm-dialog.h \
popup-commands.h \
@@ -64,7 +64,6 @@ libephymain_la_SOURCES = \
ephy-link-action.c \
ephy-location-action.c \
ephy-lockdown.c \
- ephy-navigation-action.c \
ephy-navigation-history-action.c \
ephy-notebook.c \
ephy-page-menu-action.c \
@@ -73,6 +72,7 @@ libephymain_la_SOURCES = \
ephy-shell.c \
ephy-toolbar.c \
ephy-window.c \
+ ephy-window-action.c \
pdm-dialog.c \
popup-commands.c \
prefs-dialog.c \