aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorClaudio Saavedra <csaavedra@igalia.com>2012-08-20 18:21:53 +0800
committerClaudio Saavedra <csaavedra@igalia.com>2012-09-01 02:34:00 +0800
commit42f980437991a70c387ca5e81b97805dbfa2d85d (patch)
tree1ea7daf7b8aa7d451386f616338cf682f51dddab /src/Makefile.am
parent224d74346147e3810069dc33367a49f4b3a6091c (diff)
downloadgsoc2013-epiphany-42f980437991a70c387ca5e81b97805dbfa2d85d.tar
gsoc2013-epiphany-42f980437991a70c387ca5e81b97805dbfa2d85d.tar.gz
gsoc2013-epiphany-42f980437991a70c387ca5e81b97805dbfa2d85d.tar.bz2
gsoc2013-epiphany-42f980437991a70c387ca5e81b97805dbfa2d85d.tar.lz
gsoc2013-epiphany-42f980437991a70c387ca5e81b97805dbfa2d85d.tar.xz
gsoc2013-epiphany-42f980437991a70c387ca5e81b97805dbfa2d85d.tar.zst
gsoc2013-epiphany-42f980437991a70c387ca5e81b97805dbfa2d85d.zip
ephy-embed-shell: add a frecent store to the shell
Since we will use the overview in each tab and these should share the underlying model.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 61b6fbecc..69045e306 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -146,6 +146,7 @@ epiphany_CPPFLAGS = \
-I$(top_srcdir)/lib \
-I$(top_srcdir)/lib/egg \
-I$(top_srcdir)/lib/history \
+ -I$(top_srcdir)/lib/widgets \
-I$(top_srcdir)/src/bookmarks \
-DDATADIR=\""$(datadir)"\" \
-DGNOMELOCALEDIR=\"$(datadir)/locale\" \
@@ -246,6 +247,7 @@ EPHY_GIR_H_FILES = \
$(top_srcdir)/lib/ephy-node.h \
$(top_srcdir)/lib/ephy-state.h \
$(top_srcdir)/lib/widgets/ephy-download-widget.h \
+ $(top_srcdir)/lib/widgets/ephy-frecent-store.h \
$(top_srcdir)/lib/widgets/ephy-search-entry.h \
$(top_srcdir)/src/bookmarks/ephy-bookmarks.h \
$(top_srcdir)/src/ephy-extension.h \
@@ -274,6 +276,7 @@ EPHY_GIR_C_FILES = \
$(top_srcdir)/lib/ephy-node.c \
$(top_srcdir)/lib/ephy-state.c \
$(top_srcdir)/lib/widgets/ephy-download-widget.c \
+ $(top_srcdir)/lib/widgets/ephy-frecent-store.c \
$(top_srcdir)/lib/widgets/ephy-search-entry.c \
$(top_srcdir)/src/bookmarks/ephy-bookmarks.c \
$(top_srcdir)/src/ephy-extension.c \
@@ -308,6 +311,7 @@ Epiphany-$(EPIPHANY_API_VERSION).gir: $(INTROSPECTION_SCANNER) $(EPHY_GIR_H_FILE
-I$(top_srcdir)/embed \
-I$(top_srcdir)/lib \
-I$(top_srcdir)/lib/egg \
+ -I$(top_srcdir)/lib/widgets \
-I$(top_srcdir)/src \
-I$(top_srcdir)/src/bookmarks \
$(EPHY_GIR_H_FILES) \