aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorCrispin Flowerday <gnome@flowerday.cx>2006-01-27 05:54:58 +0800
committerCrispin Flowerday <crispin@src.gnome.org>2006-01-27 05:54:58 +0800
commit026c58b8631cd0b7ab2b2d7d53a5114f7ccf0245 (patch)
treec634909931d7b4b131bf8e534e7e95fe6bbcdbfc /src/Makefile.am
parentd174065bd9c72a70670149505200648de547b011 (diff)
downloadgsoc2013-epiphany-026c58b8631cd0b7ab2b2d7d53a5114f7ccf0245.tar
gsoc2013-epiphany-026c58b8631cd0b7ab2b2d7d53a5114f7ccf0245.tar.gz
gsoc2013-epiphany-026c58b8631cd0b7ab2b2d7d53a5114f7ccf0245.tar.bz2
gsoc2013-epiphany-026c58b8631cd0b7ab2b2d7d53a5114f7ccf0245.tar.lz
gsoc2013-epiphany-026c58b8631cd0b7ab2b2d7d53a5114f7ccf0245.tar.xz
gsoc2013-epiphany-026c58b8631cd0b7ab2b2d7d53a5114f7ccf0245.tar.zst
gsoc2013-epiphany-026c58b8631cd0b7ab2b2d7d53a5114f7ccf0245.zip
Use stamp files for the dbus bindings.h files
2006-01-26 Crispin Flowerday <gnome@flowerday.cx> * src/Makefile.am: Use stamp files for the dbus bindings.h files
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am22
1 files changed, 15 insertions, 7 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 15b4ee5e6..f5420a254 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -252,7 +252,9 @@ endif
stamp_files = \
stamp-ephy-type-builtins.c \
- stamp-ephy-type-builtins.h
+ stamp-ephy-type-builtins.h \
+ stamp-ephy-dbus-server-bindings.h \
+ stamp-ephy-dbus-client-bindings.h
ephy-type-builtins.c: stamp-ephy-type-builtins.c
@true
@@ -292,15 +294,21 @@ stamp-ephy-type-builtins.h: $(INST_H_FILES) $(NOINST_H_FILES)
&& rm -f xgen-$(@F) \
&& echo timestamp > $(@F)
-ephy-dbus-server-bindings.h: $(top_srcdir)/data/epiphany-service.xml Makefile
+ephy-dbus-server-bindings.h: stamp-ephy-dbus-server-bindings.h
+ @true
+stamp-ephy-dbus-server-bindings.h: $(top_srcdir)/data/epiphany-service.xml Makefile
$(DBUS_BINDING_TOOL) --prefix=ephy_activation --mode=glib-server $< > xgen-$(@F) \
- && ( cmp -s xgen-$(@F) $(@F) || cp xgen-$(@F) $(@F) ) \
- && rm -f xgen-$(@F)
+ && ( cmp -s xgen-$(@F) $(@F:stamp-%=%) || cp xgen-$(@F) $(@F:stamp-%=%) ) \
+ && rm -f xgen-$(@F) \
+ && echo timestamp > $(@F)
-ephy-dbus-client-bindings.h: $(top_srcdir)/data/epiphany-service.xml Makefile
+ephy-dbus-client-bindings.h: stamp-ephy-dbus-client-bindings.h
+ @true
+stamp-ephy-dbus-client-bindings.h: $(top_srcdir)/data/epiphany-service.xml Makefile
$(DBUS_BINDING_TOOL) --prefix=ephy_activation --mode=glib-client $< > xgen-$(@F) \
- && ( cmp -s xgen-$(@F) $(@F) || cp xgen-$(@F) $(@F) ) \
- && rm -f xgen-$(@F)
+ && ( cmp -s xgen-$(@F) $(@F:stamp-%=%) || cp xgen-$(@F) $(@F:stamp-%=%) ) \
+ && rm -f xgen-$(@F) \
+ && echo timestamp > $(@F)
epiphany.c: epiphany.defs epiphany.override
( cd $(srcdir) && $(PYGTK_CODEGEN) \