aboutsummaryrefslogtreecommitdiffstats
path: root/omf-install/Makefile.am
diff options
context:
space:
mode:
authorPatanjali Somayaji <patanjali@codito.com>2003-03-27 01:05:07 +0800
committerPatanjali Somayaji <patanja@src.gnome.org>2003-03-27 01:05:07 +0800
commit712aae808ee329cafdcb92e78f145a50c78b89b8 (patch)
tree6dc60b00e68273e1ce42cfd7ce4dd7e79d21ada6 /omf-install/Makefile.am
parent61972bb181cc4de1537d1137e797edd7f386ae91 (diff)
downloadgsoc2013-epiphany-712aae808ee329cafdcb92e78f145a50c78b89b8.tar
gsoc2013-epiphany-712aae808ee329cafdcb92e78f145a50c78b89b8.tar.gz
gsoc2013-epiphany-712aae808ee329cafdcb92e78f145a50c78b89b8.tar.bz2
gsoc2013-epiphany-712aae808ee329cafdcb92e78f145a50c78b89b8.tar.lz
gsoc2013-epiphany-712aae808ee329cafdcb92e78f145a50c78b89b8.tar.xz
gsoc2013-epiphany-712aae808ee329cafdcb92e78f145a50c78b89b8.tar.zst
gsoc2013-epiphany-712aae808ee329cafdcb92e78f145a50c78b89b8.zip
Added help support, help manual and scrollkeeper updates
2003-03-26 Patanjali Somayaji <patanjali@codito.com> Added help support, help manual and scrollkeeper updates * configure.in (help/Makefile and help/C/Makefile for AC_OUTPUT()) * makefile.am (added "help" to SUBDIRS in Makefile.am) * omf.make (added) * xmldocs.make (added) * omf-install/Makefile.am (added) * help/Makefile.am (added) * help/C/epiphany.xml (manual xml added) * help/C/legal.xml (added) * help/C/epiphany-C.omf (omf file added) * help/C/Makefile.am (added) * help/C/figures/ephy-screenshot.png (added) * src/window-commands.c (added handler code to show manual)
Diffstat (limited to 'omf-install/Makefile.am')
-rw-r--r--omf-install/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/omf-install/Makefile.am b/omf-install/Makefile.am
new file mode 100644
index 000000000..74086afcd
--- /dev/null
+++ b/omf-install/Makefile.am
@@ -0,0 +1,33 @@
+#
+# Modify the definition of $omf_dest_dir, replacing "gdp-example1" with
+# the name of your package.
+#
+# No other modifications should be necessary.
+#
+# Note that you must configure your package with --localstatedir=/var/lib
+# so that the scrollkeeper-update command below will update the database
+# in the standard scrollkeeper directory.
+#
+# If it is impossible to configure with --localstatedir=/var/lib, then
+# modify the definition of scrollkeeper_localstate_dir so that
+# it points to the correct location. Note that you must still use
+# $(localstatedir) in this or when people build RPMs it will update
+# the real database on their system instead of the one under RPM_BUILD_ROOT.
+
+omf_dest_dir=$(datadir)/omf/epiphany
+scrollkeeper_localstate_dir = $(localstatedir)/scrollkeeper
+
+install-data-local:
+ $(mkinstalldirs) $(DESTDIR)$(omf_dest_dir)
+ -for file in $(srcdir)/*.omf; do \
+ $(INSTALL_DATA) $(srcdir)/$$file $(DESTDIR)$(omf_dest_dir); \
+ done
+ -scrollkeeper-update -p $(scrollkeeper_localstate_dir)
+
+uninstall-local:
+ -for file in $(srcdir)/*.omf; do \
+ basefile=`basename $$file`; \
+ rm -f $(omf_dest_dir)/$$basefile; \
+ done
+ -rmdir $(omf_dest_dir)
+ -scrollkeeper-update -p $(scrollkeeper_localstate_dir)