aboutsummaryrefslogtreecommitdiffstats
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorXan Lopez <xan@gnome.org>2009-12-15 17:31:47 +0800
committerXan Lopez <xan@gnome.org>2009-12-15 17:31:47 +0800
commit7a295e2c5db878dbd076c2f582cbae8aa738c3b7 (patch)
treeb0c4dc94c2b97cf7a7d5a955746d8d84eebd80f5 /lib/Makefile.am
parenta31c25320318115914e009048a4081b2a1b58f50 (diff)
downloadgsoc2013-epiphany-7a295e2c5db878dbd076c2f582cbae8aa738c3b7.tar
gsoc2013-epiphany-7a295e2c5db878dbd076c2f582cbae8aa738c3b7.tar.gz
gsoc2013-epiphany-7a295e2c5db878dbd076c2f582cbae8aa738c3b7.tar.bz2
gsoc2013-epiphany-7a295e2c5db878dbd076c2f582cbae8aa738c3b7.tar.lz
gsoc2013-epiphany-7a295e2c5db878dbd076c2f582cbae8aa738c3b7.tar.xz
gsoc2013-epiphany-7a295e2c5db878dbd076c2f582cbae8aa738c3b7.tar.zst
gsoc2013-epiphany-7a295e2c5db878dbd076c2f582cbae8aa738c3b7.zip
Move profile migration tools from src/ to lib/
We'll use them from embed/ for form password saving, and embed/ can't use code from src/
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 3ea7e1c07..58c363a73 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -20,6 +20,7 @@ NOINST_H_FILES = \
ephy-node-common.h \
ephy-object-helpers.h \
ephy-prefs.h \
+ ephy-profile-migration.h \
ephy-print-utils.h \
ephy-shlib-loader.h \
ephy-signal-accumulator.h \
@@ -57,6 +58,7 @@ libephymisc_la_SOURCES = \
ephy-node-db.c \
ephy-object-helpers.c \
ephy-prefs.h \
+ ephy-profile-migration.c \
ephy-print-utils.c \
ephy-shlib-loader.c \
ephy-signal-accumulator.c \
@@ -98,6 +100,18 @@ libephymisc_la_LIBADD += \
$(SPELLCHECKER_LIBS)
endif
+if ENABLE_NSS
+NOINST_H_FILES += \
+ ephy-nss-glue.h \
+ $(NULL)
+
+libephymisc_la_SOURCES += \
+ ephy-nss-glue.c
+ $(NULL)
+
+libephymisc_la_CFLAGS += $(NSS_CFLAGS)
+endif # ENABLE_NSS
+
BUILT_SOURCES = \
ephy-lib-type-builtins.c \
ephy-lib-type-builtins.h \