aboutsummaryrefslogtreecommitdiffstats
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorXan Lopez <xlopez@igalia.com>2011-11-24 17:37:23 +0800
committerXan Lopez <xan@igalia.com>2012-03-07 04:49:42 +0800
commit77ee0fdf4c5383f2134608e741b73f51ef30f430 (patch)
treec46e275c07d732d6e65cc45673f56f9e7fc9660a /lib/Makefile.am
parenta915b03c590e60f557d9097893601e1b1bf8c08d (diff)
downloadgsoc2013-epiphany-77ee0fdf4c5383f2134608e741b73f51ef30f430.tar
gsoc2013-epiphany-77ee0fdf4c5383f2134608e741b73f51ef30f430.tar.gz
gsoc2013-epiphany-77ee0fdf4c5383f2134608e741b73f51ef30f430.tar.bz2
gsoc2013-epiphany-77ee0fdf4c5383f2134608e741b73f51ef30f430.tar.lz
gsoc2013-epiphany-77ee0fdf4c5383f2134608e741b73f51ef30f430.tar.xz
gsoc2013-epiphany-77ee0fdf4c5383f2134608e741b73f51ef30f430.tar.zst
gsoc2013-epiphany-77ee0fdf4c5383f2134608e741b73f51ef30f430.zip
Add GObject wrapper classes for SQLite
We'll use them to implement the new history/bookmarks storage backend. Code by Martin Robinson (mrobinson@igalia.com) and Claudio Saavedra (csaavedra@igalia.com)
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 0e4869ad8..1d7a26825 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -24,6 +24,9 @@ NOINST_H_FILES = \
ephy-shlib-loader.h \
ephy-signal-accumulator.h \
ephy-smaps.h \
+ ephy-sqlite.h \
+ ephy-sqlite-connection.h \
+ ephy-sqlite-statement.h \
ephy-string.h \
ephy-time-helpers.h \
ephy-zoom.h
@@ -64,6 +67,8 @@ libephymisc_la_SOURCES = \
ephy-shlib-loader.c \
ephy-signal-accumulator.c \
ephy-smaps.c \
+ ephy-sqlite-connection.c \
+ ephy-sqlite-statement.c \
ephy-state.c \
ephy-string.c \
ephy-time-helpers.c \