aboutsummaryrefslogtreecommitdiffstats
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorChristian Persch <chpe@cvs.gnome.org>2004-10-17 21:39:12 +0800
committerChristian Persch <chpe@src.gnome.org>2004-10-17 21:39:12 +0800
commit611e5407571e19353a98292d953e90e63073ba61 (patch)
treecc306bde897a303c8f0974c6b9dd2ae0311b3947 /lib/Makefile.am
parentc21eba3c01185673b2ab4e7ceee995f6f52b6f25 (diff)
downloadgsoc2013-epiphany-611e5407571e19353a98292d953e90e63073ba61.tar
gsoc2013-epiphany-611e5407571e19353a98292d953e90e63073ba61.tar.gz
gsoc2013-epiphany-611e5407571e19353a98292d953e90e63073ba61.tar.bz2
gsoc2013-epiphany-611e5407571e19353a98292d953e90e63073ba61.tar.lz
gsoc2013-epiphany-611e5407571e19353a98292d953e90e63073ba61.tar.xz
gsoc2013-epiphany-611e5407571e19353a98292d953e90e63073ba61.tar.zst
gsoc2013-epiphany-611e5407571e19353a98292d953e90e63073ba61.zip
R lib/ephy-module-loader.c: R lib/ephy-module-loader.h: A
2004-10-17 Christian Persch <chpe@cvs.gnome.org> * lib/Makefile.am: R lib/ephy-module-loader.c: R lib/ephy-module-loader.h: A lib/ephy-module.c: (ephy_module_get_type), (ephy_module_load), (ephy_module_unload), (ephy_module_get_path), (ephy_module_new_object), (ephy_module_init), (ephy_module_finalize), (ephy_module_class_init), (ephy_module_new): A lib/ephy-module.h: s/EphyModuleLoader/EphyModule/g since "loader" now means something different. A lib/ephy-loader.c: (ephy_loader_get_type), (ephy_loader_type), (ephy_loader_get_object), (ephy_loader_release_object): A lib/ephy-loader.h: Generic object loader. A lib/ephy-shlib-loader.c: (ephy_shlib_loader_get_type), (free_loader_data), (ephy_shlib_loader_init), (ephy_shlib_loader_finalize), (find_library), (find_object), (idle_unref), (impl_get_object), (impl_release_object), (ephy_shlib_loader_iface_init), (ephy_shlib_loader_class_init): A lib/ephy-shlib-loader.h: A .so loader. * src/Makefile.am: * src/ephy-extensions-manager.c: (ephy_extensions_manager_load), (ephy_extensions_manager_unload), (ephy_extensions_manager_register), (ephy_extensions_manager_get_extensions), (free_extension_info), (free_loader_info), (find_extension_info), (ephy_extensions_manager_load_file), (find_loader), (get_loader_for_type), (attach_window), (load_extension), (detach_window), (unload_extension), (ephy_extensions_manager_load_dir), (active_extensions_notifier), (ephy_extensions_manager_init), (ephy_extensions_manager_finalize), (impl_attach_window), (impl_detach_window), (ephy_extensions_manager_class_init): * src/ephy-extensions-manager.h: Read extension descriptions from .xml, load them with the specified loader (for now, just only .so is supported). * src/ephy-shell.c: (ephy_shell_finalize), (ephy_shell_get_session), (ephy_shell_get_extensions_manager): Minor API change in extensions manager. * data/epiphany.schemas.in: Add extensions-manager-ui as default active extension. 2004-10-10 Marco Pesenti Gritti <marco@gnome.org>
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 8a7c8ff79..c90f51ac3 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -24,16 +24,18 @@ NOINST_H_FILES = \
ephy-gui.h \
ephy-langs.h \
ephy-marshal.h \
- ephy-module-loader.h \
+ ephy-module.h \
ephy-node-filter.h \
ephy-node-common.h \
ephy-prefs.h \
+ ephy-shlib-loader.h \
ephy-string.h \
ephy-stock-icons.h \
ephy-zoom.h
INST_H_FILES = \
ephy-dialog.h \
+ ephy-loader.h \
ephy-node.h \
ephy-node-db.h \
ephy-state.h
@@ -48,7 +50,8 @@ libephymisc_la_SOURCES = \
ephy-glade.c \
ephy-gui.c \
ephy-langs.c \
- ephy-module-loader.c \
+ ephy-loader.c \
+ ephy-module.c \
ephy-marshal.c \
ephy-node.c \
ephy-node.h \
@@ -56,6 +59,7 @@ libephymisc_la_SOURCES = \
ephy-node-common.h \
ephy-node-db.c \
ephy-prefs.h \
+ ephy-shlib-loader.c \
ephy-state.c \
ephy-string.c \
ephy-stock-icons.c \
@@ -75,4 +79,3 @@ ephy-marshal.h: ephy-marshal.list
EXTRA_DIST = \
ephy-marshal.list
-