aboutsummaryrefslogtreecommitdiffstats
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorXan Lopez <xan@igalia.com>2012-03-14 22:58:33 +0800
committerXan Lopez <xan@igalia.com>2012-03-14 23:01:32 +0800
commit3b6eaf03d1bb27ef42bd500a34799b82acf47c61 (patch)
tree8304db7f307747d11e2aecf38164247ba5a2422a /lib/Makefile.am
parent63d0dca04581603d862d3fd74e83c992b5c8baec (diff)
downloadgsoc2013-epiphany-3b6eaf03d1bb27ef42bd500a34799b82acf47c61.tar
gsoc2013-epiphany-3b6eaf03d1bb27ef42bd500a34799b82acf47c61.tar.gz
gsoc2013-epiphany-3b6eaf03d1bb27ef42bd500a34799b82acf47c61.tar.bz2
gsoc2013-epiphany-3b6eaf03d1bb27ef42bd500a34799b82acf47c61.tar.lz
gsoc2013-epiphany-3b6eaf03d1bb27ef42bd500a34799b82acf47c61.tar.xz
gsoc2013-epiphany-3b6eaf03d1bb27ef42bd500a34799b82acf47c61.tar.zst
gsoc2013-epiphany-3b6eaf03d1bb27ef42bd500a34799b82acf47c61.zip
Fix distcheck
Most data files are listed through EXTRA_DIST, so they are left in the top srcdir during VPATH builds. The new EphyWebView unit test needs data/pages/error.html, so distcheck was broken because ephy_file ("error.html") was failing since it looked for them in $pwd/data. To fix this, look for files in the top srcdir instead of $pwd/data, which will lead to the builddir data data dir during distcheck.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index c3965bd00..b98c70564 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -85,6 +85,7 @@ libephymisc_la_CPPFLAGS = \
-I$(top_srcdir)/lib/egg \
-DDATADIR="\"$(datadir)\"" \
-DSHARE_DIR=\"$(pkgdatadir)\" \
+ -DTOP_SRC_DATADIR=\"$(top_srcdir)/data\" \
-DEXTENSIONS_DIR=\""$(libdir)/epiphany/$(EPIPHANY_API_VERSION)/extensions"\" \
$(AM_CPPFLAGS)