aboutsummaryrefslogtreecommitdiffstats
path: root/embed/xulrunner/components/Makefile.am
diff options
context:
space:
mode:
authorChristian Persch <chpe@src.gnome.org>2007-09-14 04:35:29 +0800
committerChristian Persch <chpe@src.gnome.org>2007-09-14 04:35:29 +0800
commitc7751489980a228c7b0270fcec2823b030d2ac77 (patch)
treef917652803a9982032923d51fe46873ce8127163 /embed/xulrunner/components/Makefile.am
parentaa53ef8dd2c8174a2428b2aa360c8dd0e045543e (diff)
downloadgsoc2013-epiphany-c7751489980a228c7b0270fcec2823b030d2ac77.tar
gsoc2013-epiphany-c7751489980a228c7b0270fcec2823b030d2ac77.tar.gz
gsoc2013-epiphany-c7751489980a228c7b0270fcec2823b030d2ac77.tar.bz2
gsoc2013-epiphany-c7751489980a228c7b0270fcec2823b030d2ac77.tar.lz
gsoc2013-epiphany-c7751489980a228c7b0270fcec2823b030d2ac77.tar.xz
gsoc2013-epiphany-c7751489980a228c7b0270fcec2823b030d2ac77.tar.zst
gsoc2013-epiphany-c7751489980a228c7b0270fcec2823b030d2ac77.zip
Move components from embed/ to components/ and fix the build.
svn path=/trunk/; revision=7431
Diffstat (limited to 'embed/xulrunner/components/Makefile.am')
-rw-r--r--embed/xulrunner/components/Makefile.am73
1 files changed, 71 insertions, 2 deletions
diff --git a/embed/xulrunner/components/Makefile.am b/embed/xulrunner/components/Makefile.am
index 53796b169..ad9b5f348 100644
--- a/embed/xulrunner/components/Makefile.am
+++ b/embed/xulrunner/components/Makefile.am
@@ -3,11 +3,75 @@ NULL =
noinst_LTLIBRARIES = libephycomponents.la
libephycomponents_la_SOURCES = \
- GeckoPromptService.cpp \
- GeckoPromptService.h \
+ ContentHandler.cpp \
+ ContentHandler.h \
+ EphyAboutModule.cpp \
+ EphyAboutModule.h \
+ EphyContentPolicy.cpp \
+ EphyContentPolicy.h \
+ EphyRedirectChannel.cpp \
+ EphyRedirectChannel.h \
+ EphySidebar.cpp \
+ EphySidebar.h \
+ GeckoCookiePromptService.cpp \
+ GeckoCookiePromptService.h \
+ GeckoFormSigningDialog.cpp \
+ GeckoFormSigningDialog.h \
+ GeckoPrintService.cpp \
+ GeckoPrintService.h \
+ GeckoPrintSession.cpp \
+ GeckoPrintSession.h \
+ GeckoPromptService.cpp \
+ GeckoPromptService.h \
+ GlobalHistory.cpp \
+ GlobalHistory.h \
+ MozDownload.cpp \
+ MozDownload.h \
+ MozRegisterComponents.cpp \
+ MozRegisterComponents.h \
$(NULL)
+# if ENABLE_FILEPICKER
+# libephycomponents_la_SOURCES += \
+# FilePicker.cpp \
+# FilePicker.h
+# endif
+
+# NOTE & FIXME: Most of these are GPL not LGPL
+# if HAVE_MOZILLA_PSM
+libephycomponents_la_SOURCES += \
+ GtkNSSClientAuthDialogs.cpp \
+ GtkNSSClientAuthDialogs.h \
+ GtkNSSDialogs.cpp \
+ GtkNSSDialogs.h \
+ GtkNSSKeyPairDialogs.cpp \
+ GtkNSSKeyPairDialogs.h \
+ GtkNSSSecurityWarningDialogs.cpp\
+ GtkNSSSecurityWarningDialogs.h
+# endif
+
+# if ENABLE_SPELLCHECKER
+libephycomponents_la_SOURCES += \
+ GeckoSpellCheckEngine.cpp \
+ GeckoSpellCheckEngine.h
+# endif
+
libephycomponents_la_CPPFLAGS = \
+ -I$(top_srcdir)/lib \
+ -I$(top_srcdir)/embed \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/embed/xulrunner/src \
+ -I$(top_srcdir)/embed/xulrunner/embed \
+ -I$(top_srcdir)/embed/xulrunner/utils \
+ -I$(top_builddir)/embed/xulrunner/src \
+ -I$(top_builddir)/embed/xulrunner/embed \
+ -DSHARE_DIR=\"$(pkgdatadir)\" \
+ -DPLUGINDIR=\"$(libdir)/epiphany/$(EPIPHANY_MAJOR)/plugins\" \
+ -DMOZILLA_HOME=\"$(LIBXUL_LIBDIR)\" \
+ -DMOZILLA_PREFIX=\"$(LIBXUL_PREFIX)\" \
+ -DMOZILLA_NATIVE_PLUGINSDIR=\"$(libdir)/mozilla/plugins\" \
+ -DUA_VERSION=\"$(EPIPHANY_UA_VERSION)\" \
+ -DALLOW_PRIVATE_API \
$(LIBXUL_CXXCPPFLAGS) \
$(LIBXUL_INCLUDES) \
$(AM_CPPFLAGS)
@@ -15,6 +79,11 @@ libephycomponents_la_CPPFLAGS = \
libephycomponents_la_CXXFLAGS = \
$(LIBXUL_CXXFLAGS) \
$(GTK_CFLAGS) \
+ $(GTKPRINT_CFLAGS) \
+ $(GNOMEVFS_CFLAGS) \
+ $(GCONF_CFLAGS) \
+ $(GLADE_CFLAGS) \
+ $(GNOME_CFLAGS) \
$(AM_CXXFLAGS)
libephycomponents_la_LDFLAGS = \