aboutsummaryrefslogtreecommitdiffstats
path: root/embed/xulrunner/components/Makefile.am
diff options
context:
space:
mode:
authorChristian Persch <chpe@src.gnome.org>2007-09-13 21:25:50 +0800
committerChristian Persch <chpe@src.gnome.org>2007-09-13 21:25:50 +0800
commit582bcd3f48e7fe43f8072ec2f03109a3f4d5fe12 (patch)
tree8b155a5d349703120b4cc471baa595dc343da03f /embed/xulrunner/components/Makefile.am
parent7049570b8392a6c78c5669b96f170b02b1237f73 (diff)
downloadgsoc2013-epiphany-582bcd3f48e7fe43f8072ec2f03109a3f4d5fe12.tar
gsoc2013-epiphany-582bcd3f48e7fe43f8072ec2f03109a3f4d5fe12.tar.gz
gsoc2013-epiphany-582bcd3f48e7fe43f8072ec2f03109a3f4d5fe12.tar.bz2
gsoc2013-epiphany-582bcd3f48e7fe43f8072ec2f03109a3f4d5fe12.tar.lz
gsoc2013-epiphany-582bcd3f48e7fe43f8072ec2f03109a3f4d5fe12.tar.xz
gsoc2013-epiphany-582bcd3f48e7fe43f8072ec2f03109a3f4d5fe12.tar.zst
gsoc2013-epiphany-582bcd3f48e7fe43f8072ec2f03109a3f4d5fe12.zip
Move prompt service implementation to components/ and remove the
duplicate implementations in src/ and embed/. Doesn't build yet. svn path=/trunk/; revision=7427
Diffstat (limited to 'embed/xulrunner/components/Makefile.am')
-rw-r--r--embed/xulrunner/components/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/embed/xulrunner/components/Makefile.am b/embed/xulrunner/components/Makefile.am
index e69de29bb..53796b169 100644
--- a/embed/xulrunner/components/Makefile.am
+++ b/embed/xulrunner/components/Makefile.am
@@ -0,0 +1,30 @@
+NULL =
+
+noinst_LTLIBRARIES = libephycomponents.la
+
+libephycomponents_la_SOURCES = \
+ GeckoPromptService.cpp \
+ GeckoPromptService.h \
+ $(NULL)
+
+libephycomponents_la_CPPFLAGS = \
+ $(LIBXUL_CXXCPPFLAGS) \
+ $(LIBXUL_INCLUDES) \
+ $(AM_CPPFLAGS)
+
+libephycomponents_la_CXXFLAGS = \
+ $(LIBXUL_CXXFLAGS) \
+ $(GTK_CFLAGS) \
+ $(AM_CXXFLAGS)
+
+libephycomponents_la_LDFLAGS = \
+ $(AM_LDFLAGS)
+
+libephycomponents_la_LIBADD = \
+ $(LIBXUL_LIBS)
+
+CLEANFILES =
+ $(NULL)
+
+EXTRA_DIST = \
+ $(NULL)