aboutsummaryrefslogtreecommitdiffstats
path: root/embed/webkit/Makefile.am
diff options
context:
space:
mode:
authorXan Lopez <xan@gnome.org>2007-07-28 04:27:56 +0800
committerXan Lopez <xan@src.gnome.org>2007-07-28 04:27:56 +0800
commitc75bf8633191306efc4120fd589d0c375f286e71 (patch)
treee573b99549ca95c38ef67c9dd5d53829cb545a30 /embed/webkit/Makefile.am
parentec7067fd30fe1bd5d0b69a648359d8085328f398 (diff)
downloadgsoc2013-epiphany-c75bf8633191306efc4120fd589d0c375f286e71.tar
gsoc2013-epiphany-c75bf8633191306efc4120fd589d0c375f286e71.tar.gz
gsoc2013-epiphany-c75bf8633191306efc4120fd589d0c375f286e71.tar.bz2
gsoc2013-epiphany-c75bf8633191306efc4120fd589d0c375f286e71.tar.lz
gsoc2013-epiphany-c75bf8633191306efc4120fd589d0c375f286e71.tar.xz
gsoc2013-epiphany-c75bf8633191306efc4120fd589d0c375f286e71.tar.zst
gsoc2013-epiphany-c75bf8633191306efc4120fd589d0c375f286e71.zip
Add support for the WebKit engine, compile with --with-engine=webkit to
2007-07-27 Xan Lopez <xan@gnome.org> * Makefile.am: * configure.ac: * doc/reference/Makefile.am: * embed/Makefile.am: * embed/ephy-embed-factory.c: (ephy_embed_factory_new_object): * embed/ephy-embed-persist.c: * embed/ephy-embed-shell.c: * embed/ephy-embed.c: * embed/webkit/Makefile.am: * embed/webkit/webkit-embed-find.cpp: * embed/webkit/webkit-embed-find.h: * embed/webkit/webkit-embed-persist.cpp: * embed/webkit/webkit-embed-persist.h: * embed/webkit/webkit-embed-single.cpp: * embed/webkit/webkit-embed-single.h: * embed/webkit/webkit-embed.cpp: * embed/webkit/webkit-embed.h: * src/Makefile.am: Add support for the WebKit engine, compile with --with-engine=webkit to activate. * embed/mozilla/mozilla-embed-single.cpp: Move to the G_DEFINE_TYPE_WITH_CODE macro. svn path=/trunk/; revision=7208
Diffstat (limited to 'embed/webkit/Makefile.am')
-rw-r--r--embed/webkit/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/embed/webkit/Makefile.am b/embed/webkit/Makefile.am
new file mode 100644
index 000000000..41d6fb98a
--- /dev/null
+++ b/embed/webkit/Makefile.am
@@ -0,0 +1,23 @@
+noinst_LTLIBRARIES = libephywebkitembed.la
+
+libephywebkitembed_la_SOURCES = \
+ webkit-embed.cpp \
+ webkit-embed.h \
+ webkit-embed-find.cpp \
+ webkit-embed-find.h \
+ webkit-embed-persist.cpp \
+ webkit-embed-persist.h \
+ webkit-embed-single.cpp \
+ webkit-embed-single.h
+
+libephywebkitembed_la_CPPFLAGS = \
+ -I$(top_srcdir)/lib \
+ -I$(top_srcdir)/embed \
+ -I$(top_srcdir) \
+ $(WEBKIT_CFLAGS) \
+ -DSHARE_DIR=\"$(pkgdatadir)\" \
+ -DBUILDING_GDK__=1 \
+ -DBUILDING_CAIRO__=1 \
+ $(DEPENDENCIES_CFLAGS) \
+ $(AM_CPPFLAGS)
+