aboutsummaryrefslogtreecommitdiffstats
path: root/data/Makefile.am
diff options
context:
space:
mode:
authorVincent Untz <vuntz@gnome.org>2009-07-30 18:51:48 +0800
committerVincent Untz <vuntz@gnome.org>2009-07-30 18:51:48 +0800
commit72b49fe58f5feaa36ae4851415a76588793f1510 (patch)
tree388029e647659e812421247453a6298f2876ad29 /data/Makefile.am
parent048b02780261819c29de2b43a1c1a18d3cbb066f (diff)
downloadgsoc2013-epiphany-72b49fe58f5feaa36ae4851415a76588793f1510.tar
gsoc2013-epiphany-72b49fe58f5feaa36ae4851415a76588793f1510.tar.gz
gsoc2013-epiphany-72b49fe58f5feaa36ae4851415a76588793f1510.tar.bz2
gsoc2013-epiphany-72b49fe58f5feaa36ae4851415a76588793f1510.tar.lz
gsoc2013-epiphany-72b49fe58f5feaa36ae4851415a76588793f1510.tar.xz
gsoc2013-epiphany-72b49fe58f5feaa36ae4851415a76588793f1510.tar.zst
gsoc2013-epiphany-72b49fe58f5feaa36ae4851415a76588793f1510.zip
Move default bookmarks to separate rdf file instead of hard-coded values
Bug #300190
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am15
1 files changed, 14 insertions, 1 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index ec74a1e56..e17a252a7 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -42,6 +42,17 @@ service_DATA = $(service_in_files:.service.in=.service)
$(service_DATA): $(service_in_files) Makefile
@sed -e "s|\@bindir\@|$(bindir)|" $< > $@
+# Default bookmarks
+# We don't put translations in the resulting rdf since the code can get
+# the translations via gettext (although it can also get translations
+# from the rdf if they are there and not available via gettext)
+default_bookmarksdir = $(pkgdatadir)
+default_bookmarks_in_files = default-bookmarks.rdf.in
+default_bookmarks_DATA = $(default_bookmarks_in_files:.rdf.in=.rdf)
+$(default_bookmarks_DATA): $(default_bookmarks_in_files) Makefile $(INTLTOOL_MERGE)
+ LC_ALL=C $(INTLTOOL_MERGE) -x -u /tmp $< $@.tmp
+ sed -e "s|\@pkgdatadir\@|$(pkgdatadir)|g" $@.tmp > $@ || rm -f $@.tmp
+ rm -f $@.tmp
install-data-local: $(schema_DATA)
if GCONF_SCHEMAS_INSTALL
@@ -63,6 +74,7 @@ EXTRA_DIST = \
$(xsl_DATA) \
$(service_DATA) \
$(m4data_DATA) \
+ $(default_bookmarks_in_files) \
epiphany-service.xml \
check-mime.py
@@ -70,4 +82,5 @@ DISTCLEANFILES = \
$(service_DATA) \
$(schema_in_files:.schemas.in=.schemas) \
$(pkgconfig_DATA) \
- $(desktop_DATA)
+ $(desktop_DATA) \
+ $(default_bookmarks_DATA)