aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Persch <chpe@cvs.gnome.org>2004-09-25 21:22:27 +0800
committerChristian Persch <chpe@src.gnome.org>2004-09-25 21:22:27 +0800
commitce6e072e9619efd9ac093080ad33ad2bbe6bf604 (patch)
treed212a34ddaa184c39740fa450ceac5f67cebb5b6 /configure.ac
parent0a635fdfd785c25386198b957aa5cd4e640c2cd3 (diff)
downloadgsoc2013-epiphany-ce6e072e9619efd9ac093080ad33ad2bbe6bf604.tar
gsoc2013-epiphany-ce6e072e9619efd9ac093080ad33ad2bbe6bf604.tar.gz
gsoc2013-epiphany-ce6e072e9619efd9ac093080ad33ad2bbe6bf604.tar.bz2
gsoc2013-epiphany-ce6e072e9619efd9ac093080ad33ad2bbe6bf604.tar.lz
gsoc2013-epiphany-ce6e072e9619efd9ac093080ad33ad2bbe6bf604.tar.xz
gsoc2013-epiphany-ce6e072e9619efd9ac093080ad33ad2bbe6bf604.tar.zst
gsoc2013-epiphany-ce6e072e9619efd9ac093080ad33ad2bbe6bf604.zip
Mozilla API changes.
2004-09-25 Christian Persch <chpe@cvs.gnome.org> * configure.ac: * embed/mozilla/GlobalHistory.cpp: * embed/mozilla/mozilla-embed-single.cpp: Mozilla API changes.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 23 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index fc7f60a34..3de59a622 100644
--- a/configure.ac
+++ b/configure.ac
@@ -298,6 +298,24 @@ AC_COMPILE_IFELSE(
AC_MSG_RESULT([$result])
+dnl changed in 1.8a4
+
+AC_MSG_CHECKING([for whether nsIGlobalHistory2::AddURI takes a referrer])
+
+AC_COMPILE_IFELSE(
+ [AC_LANG_PROGRAM(
+ [[#include <nsIURI.h>
+ #include <nsIGlobalHistory.h>
+ #include <docshell/nsIGlobalHistory2.h>
+ #include <history/nsIBrowserHistory.h>]],
+ [[nsIBrowserHistory *p;
+ p->AddURI(nsnull,PR_FALSE,PR_FALSE,nsnull);]]
+ )],
+ [AC_DEFINE([MOZ_NSIBROWSERHISTORY_ADDURI_WITH_REFERRER],[1],[dummy]) result=yes],
+ [result=no])
+
+AC_MSG_RESULT([$result])
+
dnl Changed from char* to nsACString& in mozilla 1.8a2
AC_MSG_CHECKING([whether nsIProtocolProxyService::ConfigureFromPAC expects nsACString&])
@@ -330,6 +348,11 @@ AC_COMPILE_IFELSE(
AC_MSG_RESULT([$result])
+dnl changed from nsIXULChromeRegistry in 1.8a4
+
+AC_CHECK_FILE([$MOZILLA_INCLUDE_ROOT/chrome/nsIChromeRegistrySea.h],
+ [AC_DEFINE([HAVE_CHROME_NSICHROMEREGISTRYSEA_H], [1], [Define if nsIChromeRegistrySea.h exists])])
+
dnl check for broken reload in GtkMozEmbed
dnl FIXME: I have NO IDEA how to do this. For now, just always enable our workaround
dnl