aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Persch <chpe@cvs.gnome.org>2006-03-13 06:22:58 +0800
committerChristian Persch <chpe@src.gnome.org>2006-03-13 06:22:58 +0800
commitbf1cded729e758363cae0aa10caf107f8f4a5685 (patch)
treee5c3f262f96c281e9941526ceb641ef9f6149196 /configure.ac
parent9ed0ae9db8339593a110d135ea4d2cd23eef1440 (diff)
downloadgsoc2013-epiphany-bf1cded729e758363cae0aa10caf107f8f4a5685.tar
gsoc2013-epiphany-bf1cded729e758363cae0aa10caf107f8f4a5685.tar.gz
gsoc2013-epiphany-bf1cded729e758363cae0aa10caf107f8f4a5685.tar.bz2
gsoc2013-epiphany-bf1cded729e758363cae0aa10caf107f8f4a5685.tar.lz
gsoc2013-epiphany-bf1cded729e758363cae0aa10caf107f8f4a5685.tar.xz
gsoc2013-epiphany-bf1cded729e758363cae0aa10caf107f8f4a5685.tar.zst
gsoc2013-epiphany-bf1cded729e758363cae0aa10caf107f8f4a5685.zip
Set different exit codes when exiting from different places in the test
2006-03-12 Christian Persch <chpe@cvs.gnome.org> * configure.ac: * m4/gecko.m4: Set different exit codes when exiting from different places in the test program, so we can see the cause of the failure in config.log.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d82b6237a..961175ef0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -278,10 +278,12 @@ GECKO_RUN_IFELSE([],
[GECKO_XPCOM_PROGRAM(
[[#include <nsIComponentRegistrar.h>]],
[[
+status = 99;
nsCOMPtr<nsIComponentRegistrar> registrar;
rv = NS_GetComponentRegistrar (getter_AddRefs (registrar));
if (NS_FAILED (rv)) break;
+status = 98;
nsCID *classID = nsnull;
rv = registrar->ContractIDToCID ("@mozilla.org/typeaheadfind;1", &classID);
if (NS_FAILED (rv) || !classID) break;
@@ -289,7 +291,7 @@ if (NS_FAILED (rv) || !classID) break;
nsCID badClassID = { 0x46590685, 0xbc00, 0x4aac,
{ 0xab, 0xed, 0x2c, 0x10, 0xa5, 0xb9, 0x45, 0xa4 } };
-retval = ! classID->Equals (badClassID);
+status = classID->Equals (badClassID) ? 97 : EXIT_SUCCESS;
]]
)],
[have_broken_typeaheadfind=no],