aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Persch <chpe@gnome.org>2007-09-10 05:11:39 +0800
committerChristian Persch <chpe@src.gnome.org>2007-09-10 05:11:39 +0800
commitb3a75061677399de19355802c54c4d355653f284 (patch)
tree689385d476a8034eb7d5fd1d7939b7b01b6468eb /configure.ac
parent0e3d0325dab1bfa25b1af72cc8b1f8dcddfa9dc7 (diff)
downloadgsoc2013-epiphany-b3a75061677399de19355802c54c4d355653f284.tar
gsoc2013-epiphany-b3a75061677399de19355802c54c4d355653f284.tar.gz
gsoc2013-epiphany-b3a75061677399de19355802c54c4d355653f284.tar.bz2
gsoc2013-epiphany-b3a75061677399de19355802c54c4d355653f284.tar.lz
gsoc2013-epiphany-b3a75061677399de19355802c54c4d355653f284.tar.xz
gsoc2013-epiphany-b3a75061677399de19355802c54c4d355653f284.tar.zst
gsoc2013-epiphany-b3a75061677399de19355802c54c4d355653f284.zip
A m4/libxul.m4: Integrate the "xulrunner" backend with configure. Not
2007-09-09 Christian Persch <chpe@gnome.org> * configure.ac: * embed/Makefile.am: * embed/ephy-embed-factory.c: (ephy_embed_factory_new_object): * m4/gecko.m4: A m4/libxul.m4: * src/Makefile.am: Integrate the "xulrunner" backend with configure. Not building yet. svn path=/trunk/; revision=7359
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac67
1 files changed, 57 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 58cb668d7..ee669dded 100644
--- a/configure.ac
+++ b/configure.ac
@@ -171,9 +171,9 @@ fi
AC_MSG_CHECKING(for which engine to use)
AC_ARG_WITH([engine],
- AS_HELP_STRING([--with-engine@<:@=mozilla|webkit@:>@],
+ AS_HELP_STRING([--with-engine@<:@=mozilla|webkit|xulrunner@:>@],
[Which engine to build against @<:@mozilla@:>@]),
- [], [with_engine="mozilla"])
+ [],[with_engine="mozilla"])
AC_MSG_RESULT($with_engine)
AC_SUBST([with_engine])
@@ -182,10 +182,9 @@ AC_SUBST([with_engine])
# Mozilla
# *******
-GECKO_INIT([GECKO], [gecko_found=yes],[gecko_found=no])
+if test "$with_engine" = "mozilla"; then
-AM_CONDITIONAL([WITH_GECKO_ENGINE], [test "$with_engine" = "mozilla"])
-if test "$with_engine" = "mozilla" ; then
+GECKO_INIT([GECKO])
AC_DEFINE([WITH_GECKO_ENGINE],[1],[Define if you wish to enable mozilla engine])
@@ -343,17 +342,38 @@ REQUIRED_EXTENSIONS="cookie,permissions"
GECKO_CHECK_CONTRACTIDS([$REQUIRED_CONTRACTS],
[],[AC_MSG_ERROR([$gecko_cv_gecko needs to be compiled with at least --enable-extensions=default,$REQUIRED_EXTENSIONS])])
-fi # with_engine = gecko
+fi # with_engine = mozilla
+GECKO_DEFINES
+AM_CONDITIONAL([WITH_GECKO_ENGINE], [test "$with_engine" = "mozilla"])
AM_CONDITIONAL([HAVE_XULRUNNER],[test "$gecko_cv_gecko" = "xulrunner"])
AM_CONDITIONAL([HAVE_MOZILLA_PSM],[test "$enable_psm" = "yes" -a "$have_psm" = "yes"])
AM_CONDITIONAL([ENABLE_FILEPICKER],[test "$enable_filepicker" = "yes"])
-# *******************************
-# webkit renderer
-# *******************************
+# *********
+# Xulrunner
+# *********
+
+# This is the mozilla backend for xulrunner 1.9
+
+if test "$with_engine" = "xulrunner"; then
+
+LIBXUL_INIT
+
+WEASEL_UA_VERSION=3.0
+AC_SUBST([WEASEL_UA_VERSION])
+
+
+fi
+
+LIBXUL_DEFINES
+
+AM_CONDITIONAL([WITH_XULRUNNER_ENGINE],[test "$with_engine" = "xulrunner"])
+
+# ******
+# WebKit
+# ******
-AM_CONDITIONAL([WITH_WEBKIT_ENGINE], test "$with_engine" = "webkit")
if test "$with_engine" = "webkit" ; then
AC_DEFINE([WITH_WEBKIT_ENGINE],[1],[Define if you wish to enable webkit engine])
PKG_CHECK_MODULES([WEBKIT], WebKitGdk)
@@ -361,6 +381,8 @@ if test "$with_engine" = "webkit" ; then
AC_SUBST([WEBKIT_LIBS])
fi # with_engine = webkit
+AM_CONDITIONAL([WITH_WEBKIT_ENGINE], test "$with_engine" = "webkit")
+
# ***************
# Multimedia keys
# ***************
@@ -720,6 +742,31 @@ po/Makefile.in
[],
[EPIPHANY_API_VERSION=$EPIPHANY_API_VERSION])
+# new gecko embedding
+
+PKG_CHECK_MODULES([GTK],[gtk+-2.0 >= $GTK_REQUIRED])
+
+# compat cruft
+GGE_VERSION=0
+AC_SUBST([GGE_VERSION])
+
+GGE_API_VERSION=0
+AC_SUBST([GGE_API_VERSION])
+
+AC_CONFIG_FILES([
+embed/xulrunner/Makefile
+embed/xulrunner/src/Makefile
+embed/xulrunner/embed/Makefile
+embed/xulrunner/data/Makefile
+embed/xulrunner/bindings/Makefile
+embed/xulrunner/bindings/python/Makefile
+embed/xulrunner/tests/Makefile
+])
+
+AC_CONFIG_FILES([
+embed/xulrunner/data/gnome-gecko-embed-${GGE_API_VERSION}.pc:embed/xulrunner/data/gnome-gecko-embed.pc.in
+],[],[GGE_API_VERSION=$GGE_API_VERSION])
+
AC_OUTPUT
# *************************************