aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Persch <chpe@cvs.gnome.org>2004-11-25 21:51:57 +0800
committerChristian Persch <chpe@src.gnome.org>2004-11-25 21:51:57 +0800
commit7ee1915ef8101e1cac5b9a2d5c858aac371d6367 (patch)
tree7b2331141eb8748f415b130375f20a8f047cd542 /configure.ac
parentb0521a16c246aea0742fb25e5195c817de1d2326 (diff)
downloadgsoc2013-epiphany-7ee1915ef8101e1cac5b9a2d5c858aac371d6367.tar
gsoc2013-epiphany-7ee1915ef8101e1cac5b9a2d5c858aac371d6367.tar.gz
gsoc2013-epiphany-7ee1915ef8101e1cac5b9a2d5c858aac371d6367.tar.bz2
gsoc2013-epiphany-7ee1915ef8101e1cac5b9a2d5c858aac371d6367.tar.lz
gsoc2013-epiphany-7ee1915ef8101e1cac5b9a2d5c858aac371d6367.tar.xz
gsoc2013-epiphany-7ee1915ef8101e1cac5b9a2d5c858aac371d6367.tar.zst
gsoc2013-epiphany-7ee1915ef8101e1cac5b9a2d5c858aac371d6367.zip
Check for iso-codes package.
2004-11-25 Christian Persch <chpe@cvs.gnome.org> * configure.ac: Check for iso-codes package. * data/glade/prefs-dialog.glade: * lib/ephy-langs.c: (ephy_langs_bind_iso_domains), (read_iso_639_entry), (read_iso_3166_entry), (load_iso_entries), (ephy_langs_iso_639_table), (ephy_langs_iso_3166_table): * lib/ephy-langs.h: Load language and locales list from iso-codes package, if available. * src/prefs-dialog.c: (prefs_dialog_finalize), (add_lang_dialog_selection_changed), (add_lang_dialog_response_cb), (get_name_for_lang_code), (add_system_language_entry), (setup_add_language_dialog), (create_language_section): If the iso-codes package is available, use that to translate language names and offer a wider variety of languages. Fixes bug #155498.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac29
1 files changed, 27 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index fb186d61e..b2c876a76 100644
--- a/configure.ac
+++ b/configure.ac
@@ -364,7 +364,7 @@ AC_MSG_RESULT([$result])
dnl Added in 1.8a6 on trunk
dnl https://bugzilla.mozilla.org/show_bug.cgi?id=223310
-AC_MSG_CHECKING([whether nsIKeygenThread takes an nsIObserver])
+AC_MSG_CHECKING([whether nsIKeygenThread::StartKeyGeneration takes an nsIObserver])
AC_COMPILE_IFELSE(
[AC_LANG_PROGRAM(
@@ -429,9 +429,34 @@ fi
dnl *******************************
dnl Internationalization
dnl *******************************
-dnl Add the languages which your application supports here.
+AC_MSG_CHECKING([for iso-codes package])
+have_iso_codes=no
+if $PKG_CONFIG --exists iso-codes --atleast-version=0.35; then
+ have_iso_codes=yes
+fi
+AC_MSG_RESULT([$have_iso_codes])
+
+if test "x$have_iso_codes" = "xyes"; then
+ AC_MSG_CHECKING([whether iso-codes has iso-639 and iso-3166 domains])
+ if $PKG_CONFIG --variable=domains iso-codes | grep -q 639 && \
+ $PKG_CONFIG --variable=domains iso-codes | grep -q 3166 ; then
+ result=yes
+ else
+ result=no
+ have_iso_codes=no
+ fi
+ AC_MSG_RESULT([$result])
+fi
+
+if test "x$have_iso_codes" = "xyes"; then
+ AC_DEFINE_UNQUOTED([ISO_CODES_PREFIX],["`$PKG_CONFIG --variable=prefix iso-codes`"],[ISO codes prefix])
+ AC_DEFINE([HAVE_ISO_CODES],[1],[Define if you have the iso-codes package])
+fi
+
+dnl Add the languages which your application supports here.
ALL_LINGUAS="am ar az be bg bn bs ca cs cy da de el en_CA en_GB es et eu fa fi fr ga gu he hi hr hu id is it ja ko li lt mi mk ml mn ms nb ne nl nn no pa pl pt pt_BR ro ru sk sl sq sr sr@Latn sv ta th tk tr uk vi wa zh_CN zh_TW"
+
GETTEXT_PACKAGE=epiphany
AC_SUBST([GETTEXT_PACKAGE])
AC_DEFINE_UNQUOTED([GETTEXT_PACKAGE], ["$GETTEXT_PACKAGE"], [Gettext package])