aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Persch <chpe@gnome.org>2007-09-11 03:37:33 +0800
committerChristian Persch <chpe@src.gnome.org>2007-09-11 03:37:33 +0800
commit5419e4d4d29bf4896fcf194af4a7f98a24841e16 (patch)
tree0aa61c9b2fefa7c975b1364ba1d10051976c6e61 /configure.ac
parent3bfcd08768b43b69dadc9aa0dabbff7a0f3e395c (diff)
downloadgsoc2013-epiphany-5419e4d4d29bf4896fcf194af4a7f98a24841e16.tar
gsoc2013-epiphany-5419e4d4d29bf4896fcf194af4a7f98a24841e16.tar.gz
gsoc2013-epiphany-5419e4d4d29bf4896fcf194af4a7f98a24841e16.tar.bz2
gsoc2013-epiphany-5419e4d4d29bf4896fcf194af4a7f98a24841e16.tar.lz
gsoc2013-epiphany-5419e4d4d29bf4896fcf194af4a7f98a24841e16.tar.xz
gsoc2013-epiphany-5419e4d4d29bf4896fcf194af4a7f98a24841e16.tar.zst
gsoc2013-epiphany-5419e4d4d29bf4896fcf194af4a7f98a24841e16.zip
Error out if the C++ compiler wasn't found. Bug #475360.
2007-09-10 Christian Persch <chpe@gnome.org> * configure.ac: Error out if the C++ compiler wasn't found. Bug #475360. svn path=/trunk/; revision=7378
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index ee669dded..cb903955c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -47,12 +47,21 @@ AC_PROG_LIBTOOL
AC_ISC_POSIX
AC_PROG_CC
-AC_PROG_CXX
AM_PROG_CC_STDC
AC_HEADER_STDC
+
+AC_PROG_CXX
+
AC_PATH_PROG([GLIB_GENMARSHAL], [glib-genmarshal])
AC_PATH_PROG([GLIB_MKENUMS],[glib-mkenums])
+# Check whether a C++ was found (AC_PROG_CXX sets $CXX to "g++" even when it
+# doesn't exist)
+
+AC_LANG_PUSH([C++])
+AC_COMPILE_IFELSE([AC_LANG_PROGRAM([],[])],[],[AC_MSG_ERROR([No C++ compiler found])])
+AC_LANG_POP([C++])
+
IT_PROG_INTLTOOL([0.35.0])
PKG_PROG_PKG_CONFIG