aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Persch <chpe@cvs.gnome.org>2005-03-22 03:49:03 +0800
committerChristian Persch <chpe@src.gnome.org>2005-03-22 03:49:03 +0800
commit10093dee9948bfb14bca7228539e20a882c0fb38 (patch)
treee61aa5057a9f0ba77b1e46b46aab6ed789bf0388 /configure.ac
parentfc3b779f2b1d3f2b665a5deb2ec5c3e5fe2a720d (diff)
downloadgsoc2013-epiphany-10093dee9948bfb14bca7228539e20a882c0fb38.tar
gsoc2013-epiphany-10093dee9948bfb14bca7228539e20a882c0fb38.tar.gz
gsoc2013-epiphany-10093dee9948bfb14bca7228539e20a882c0fb38.tar.bz2
gsoc2013-epiphany-10093dee9948bfb14bca7228539e20a882c0fb38.tar.lz
gsoc2013-epiphany-10093dee9948bfb14bca7228539e20a882c0fb38.tar.xz
gsoc2013-epiphany-10093dee9948bfb14bca7228539e20a882c0fb38.tar.zst
gsoc2013-epiphany-10093dee9948bfb14bca7228539e20a882c0fb38.zip
Oh the joys of mozilla API changes :P
2005-03-21 Christian Persch <chpe@cvs.gnome.org> * configure.ac: * embed/mozilla/ContentHandler.cpp: Oh the joys of mozilla API changes :P
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 22 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 760adc7ae..d823ddd36 100644
--- a/configure.ac
+++ b/configure.ac
@@ -419,6 +419,26 @@ AC_COMPILE_IFELSE(
AC_MSG_RESULT([$result])
+dnl Changed from PRBool to PRUin32 in 1.8b2
+
+AC_MSG_CHECKING([for nsIHelperAppLauncherDialog::Show arguments])
+
+AC_COMPILE_IFELSE(
+ [AC_LANG_SOURCE(
+ [[#include <exthandler/nsIHelperAppLauncherDialog.h>
+
+ class Test : public nsIHelperAppLauncherDialog
+ { public: NS_DECL_NSIHELPERAPPLAUNCHERDIALOG };
+
+ NS_IMETHODIMP Test::Show(nsIHelperAppLauncher *aLauncher, nsISupports *aContext, PRUint32 aReason)
+ { return NS_ERROR_NOT_IMPLEMENTED; }
+ ]]
+ )],
+ [AC_DEFINE([MOZ_NSIHELPERAPPLAUNCHERDIALOG_UNSIGNED],[1],[Define if nsIHelperAppLauncherDialog::Show takes unsigned integer]) result=unsigned],
+ [result=signed])
+
+AC_MSG_RESULT([$result])
+
dnl exists since 1.8a6
AC_CHECK_FILE([$MOZILLA_INCLUDE_ROOT/nsITransfer.h],
@@ -574,6 +594,8 @@ fi
if test "x$have_iso_codes" = "xyes"; then
AC_DEFINE_UNQUOTED([ISO_CODES_PREFIX],["`$PKG_CONFIG --variable=prefix iso-codes`"],[ISO codes prefix])
AC_DEFINE([HAVE_ISO_CODES],[1],[Define if you have the iso-codes package])
+else
+ AC_MSG_ERROR([iso-codes is required])
fi
dnl Translators: new languages must be added to the po/LINGUAS file