aboutsummaryrefslogtreecommitdiffstats
path: root/ubuntu-online-accounts/cc-plugins/Makefile.am
diff options
context:
space:
mode:
authorGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2012-07-18 16:11:39 +0800
committerGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2012-07-24 22:20:03 +0800
commit70ea840bfec883f883b748e937e28f68d9f0870f (patch)
tree7eb556cceb2dab8ac057daa9e5c58227d353a7a9 /ubuntu-online-accounts/cc-plugins/Makefile.am
parentbc953560bc9db4818874cddd855c5d06241994df (diff)
downloadgsoc2013-empathy-70ea840bfec883f883b748e937e28f68d9f0870f.tar
gsoc2013-empathy-70ea840bfec883f883b748e937e28f68d9f0870f.tar.gz
gsoc2013-empathy-70ea840bfec883f883b748e937e28f68d9f0870f.tar.bz2
gsoc2013-empathy-70ea840bfec883f883b748e937e28f68d9f0870f.tar.lz
gsoc2013-empathy-70ea840bfec883f883b748e937e28f68d9f0870f.tar.xz
gsoc2013-empathy-70ea840bfec883f883b748e937e28f68d9f0870f.tar.zst
gsoc2013-empathy-70ea840bfec883f883b748e937e28f68d9f0870f.zip
Hook cc-plugins to the build system
https://bugzilla.gnome.org/show_bug.cgi?id=680448
Diffstat (limited to 'ubuntu-online-accounts/cc-plugins/Makefile.am')
-rw-r--r--ubuntu-online-accounts/cc-plugins/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/ubuntu-online-accounts/cc-plugins/Makefile.am b/ubuntu-online-accounts/cc-plugins/Makefile.am
new file mode 100644
index 000000000..192a378c1
--- /dev/null
+++ b/ubuntu-online-accounts/cc-plugins/Makefile.am
@@ -0,0 +1,16 @@
+SUBDIRS = providers services
+
+plugindir = $(ACCOUNTS_PROVIDER_PLUGIN_DIR)
+
+INCLUDES = \
+ -I$(top_builddir) \
+ -I$(top_srcdir) \
+ -DLOCALEDIR=\""$(datadir)/locale"\" \
+ $(UOA_CFLAGS) \
+ $(WARN_CFLAGS) \
+ $(ERROR_CFLAGS) \
+ $(DISABLE_DEPRECATED) \
+ $(EMPATHY_CFLAGS)
+
+plugin_LTLIBRARIES = \
+ $(NULL)