aboutsummaryrefslogtreecommitdiffstats
path: root/ubuntu-online-accounts/cc-plugins/Makefile.am
diff options
context:
space:
mode:
authorGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2012-07-18 18:48:46 +0800
committerGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2012-07-24 22:20:04 +0800
commit3d004d7ebe17b0a139ef38cbd4e5631940210b78 (patch)
tree3b0a3fb92406e4148095acdc0d3f351e9c9f0f7c /ubuntu-online-accounts/cc-plugins/Makefile.am
parente296ad8a3b6dd5049caa9ea6b739a34d9d16dea6 (diff)
downloadgsoc2013-empathy-3d004d7ebe17b0a139ef38cbd4e5631940210b78.tar
gsoc2013-empathy-3d004d7ebe17b0a139ef38cbd4e5631940210b78.tar.gz
gsoc2013-empathy-3d004d7ebe17b0a139ef38cbd4e5631940210b78.tar.bz2
gsoc2013-empathy-3d004d7ebe17b0a139ef38cbd4e5631940210b78.tar.lz
gsoc2013-empathy-3d004d7ebe17b0a139ef38cbd4e5631940210b78.tar.xz
gsoc2013-empathy-3d004d7ebe17b0a139ef38cbd4e5631940210b78.tar.zst
gsoc2013-empathy-3d004d7ebe17b0a139ef38cbd4e5631940210b78.zip
Generate plugins for most protocols
https://bugzilla.gnome.org/show_bug.cgi?id=680448
Diffstat (limited to 'ubuntu-online-accounts/cc-plugins/Makefile.am')
-rw-r--r--ubuntu-online-accounts/cc-plugins/Makefile.am158
1 files changed, 157 insertions, 1 deletions
diff --git a/ubuntu-online-accounts/cc-plugins/Makefile.am b/ubuntu-online-accounts/cc-plugins/Makefile.am
index 2b6029807..6effb6c24 100644
--- a/ubuntu-online-accounts/cc-plugins/Makefile.am
+++ b/ubuntu-online-accounts/cc-plugins/Makefile.am
@@ -15,9 +15,77 @@ INCLUDES = \
$(EMPATHY_CFLAGS)
plugin_LTLIBRARIES = \
- libjabber.la \
+ libaim.la\
+ libgadugadu.la\
+ libgroupwise.la\
+ libicq.la\
+ libirc.la\
+ libjabber.la\
+ libmxit.la\
+ libmyspace.la\
+ libsip.la\
+ liblocal-xmpp.la\
+ libsametime.la\
+ libyahoojp.la\
+ libyahoo.la\
+ libzephyr.la \
$(NULL)
+libaim_la_SOURCES = \
+ empathy-accounts-plugin.c \
+ empathy-accounts-plugin.h \
+ empathy-accounts-plugin-widget.c \
+ empathy-accounts-plugin-widget.h
+libaim_la_LDFLAGS = -module -avoid-version
+libaim_la_LIBADD = \
+ $(UOA_LIBS) \
+ $(top_builddir)/libempathy-gtk/libempathy-gtk.la
+
+
+libgadugadu_la_SOURCES = \
+ empathy-accounts-plugin.c \
+ empathy-accounts-plugin.h \
+ empathy-accounts-plugin-widget.c \
+ empathy-accounts-plugin-widget.h
+libgadugadu_la_LDFLAGS = -module -avoid-version
+libgadugadu_la_LIBADD = \
+ $(UOA_LIBS) \
+ $(top_builddir)/libempathy-gtk/libempathy-gtk.la
+
+
+libgroupwise_la_SOURCES = \
+ empathy-accounts-plugin.c \
+ empathy-accounts-plugin.h \
+ empathy-accounts-plugin-widget.c \
+ empathy-accounts-plugin-widget.h
+libgroupwise_la_LDFLAGS = -module -avoid-version
+libgroupwise_la_LIBADD = \
+ $(UOA_LIBS) \
+ $(top_builddir)/libempathy-gtk/libempathy-gtk.la
+
+
+libicq_la_SOURCES = \
+ empathy-accounts-plugin.c \
+ empathy-accounts-plugin.h \
+ empathy-accounts-plugin-widget.c \
+ empathy-accounts-plugin-widget.h
+libicq_la_LDFLAGS = -module -avoid-version
+libicq_la_LIBADD = \
+ $(UOA_LIBS) \
+ $(top_builddir)/libempathy-gtk/libempathy-gtk.la
+
+
+libirc_la_SOURCES = \
+ empathy-accounts-plugin.c \
+ empathy-accounts-plugin.h \
+ empathy-accounts-plugin-widget.c \
+ empathy-accounts-plugin-widget.h
+libirc_la_LDFLAGS = -module -avoid-version
+libirc_la_LIBADD = \
+ $(UOA_LIBS) \
+ $(top_builddir)/libempathy-gtk/libempathy-gtk.la
+
+
libjabber_la_SOURCES = \
empathy-accounts-plugin.c \
empathy-accounts-plugin.h \
@@ -27,3 +95,91 @@ libjabber_la_LDFLAGS = -module -avoid-version
libjabber_la_LIBADD = \
$(UOA_LIBS) \
$(top_builddir)/libempathy-gtk/libempathy-gtk.la
+
+
+libmxit_la_SOURCES = \
+ empathy-accounts-plugin.c \
+ empathy-accounts-plugin.h \
+ empathy-accounts-plugin-widget.c \
+ empathy-accounts-plugin-widget.h
+libmxit_la_LDFLAGS = -module -avoid-version
+libmxit_la_LIBADD = \
+ $(UOA_LIBS) \
+ $(top_builddir)/libempathy-gtk/libempathy-gtk.la
+
+
+libmyspace_la_SOURCES = \
+ empathy-accounts-plugin.c \
+ empathy-accounts-plugin.h \
+ empathy-accounts-plugin-widget.c \
+ empathy-accounts-plugin-widget.h
+libmyspace_la_LDFLAGS = -module -avoid-version
+libmyspace_la_LIBADD = \
+ $(UOA_LIBS) \
+ $(top_builddir)/libempathy-gtk/libempathy-gtk.la
+
+
+libsip_la_SOURCES = \
+ empathy-accounts-plugin.c \
+ empathy-accounts-plugin.h \
+ empathy-accounts-plugin-widget.c \
+ empathy-accounts-plugin-widget.h
+libsip_la_LDFLAGS = -module -avoid-version
+libsip_la_LIBADD = \
+ $(UOA_LIBS) \
+ $(top_builddir)/libempathy-gtk/libempathy-gtk.la
+
+
+liblocal_xmpp_la_SOURCES = \
+ empathy-accounts-plugin.c \
+ empathy-accounts-plugin.h \
+ empathy-accounts-plugin-widget.c \
+ empathy-accounts-plugin-widget.h
+liblocal_xmpp_la_LDFLAGS = -module -avoid-version
+liblocal_xmpp_la_LIBADD = \
+ $(UOA_LIBS) \
+ $(top_builddir)/libempathy-gtk/libempathy-gtk.la
+
+
+libsametime_la_SOURCES = \
+ empathy-accounts-plugin.c \
+ empathy-accounts-plugin.h \
+ empathy-accounts-plugin-widget.c \
+ empathy-accounts-plugin-widget.h
+libsametime_la_LDFLAGS = -module -avoid-version
+libsametime_la_LIBADD = \
+ $(UOA_LIBS) \
+ $(top_builddir)/libempathy-gtk/libempathy-gtk.la
+
+
+libyahoojp_la_SOURCES = \
+ empathy-accounts-plugin.c \
+ empathy-accounts-plugin.h \
+ empathy-accounts-plugin-widget.c \
+ empathy-accounts-plugin-widget.h
+libyahoojp_la_LDFLAGS = -module -avoid-version
+libyahoojp_la_LIBADD = \
+ $(UOA_LIBS) \
+ $(top_builddir)/libempathy-gtk/libempathy-gtk.la
+
+
+libyahoo_la_SOURCES = \
+ empathy-accounts-plugin.c \
+ empathy-accounts-plugin.h \
+ empathy-accounts-plugin-widget.c \
+ empathy-accounts-plugin-widget.h
+libyahoo_la_LDFLAGS = -module -avoid-version
+libyahoo_la_LIBADD = \
+ $(UOA_LIBS) \
+ $(top_builddir)/libempathy-gtk/libempathy-gtk.la
+
+
+libzephyr_la_SOURCES = \
+ empathy-accounts-plugin.c \
+ empathy-accounts-plugin.h \
+ empathy-accounts-plugin-widget.c \
+ empathy-accounts-plugin-widget.h
+libzephyr_la_LDFLAGS = -module -avoid-version
+libzephyr_la_LIBADD = \
+ $(UOA_LIBS) \
+ $(top_builddir)/libempathy-gtk/libempathy-gtk.la