aboutsummaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorxclaesse <xclaesse@4ee84921-47dd-4033-b63a-18d7a039a3e4>2007-12-29 23:58:47 +0800
committerxclaesse <xclaesse@4ee84921-47dd-4033-b63a-18d7a039a3e4>2007-12-29 23:58:47 +0800
commita4004017570744524ff2d0af3efab045821fd46f (patch)
tree9a15f253d9c45a90a8794143ecdd854650d58af1 /tests/Makefile.am
parent0cfd80847f0d66967f56c7d6b3eb46793f725859 (diff)
downloadgsoc2013-empathy-a4004017570744524ff2d0af3efab045821fd46f.tar
gsoc2013-empathy-a4004017570744524ff2d0af3efab045821fd46f.tar.gz
gsoc2013-empathy-a4004017570744524ff2d0af3efab045821fd46f.tar.bz2
gsoc2013-empathy-a4004017570744524ff2d0af3efab045821fd46f.tar.lz
gsoc2013-empathy-a4004017570744524ff2d0af3efab045821fd46f.tar.xz
gsoc2013-empathy-a4004017570744524ff2d0af3efab045821fd46f.tar.zst
gsoc2013-empathy-a4004017570744524ff2d0af3efab045821fd46f.zip
Revert "merge git work"
This reverts commit 0cfd80847f0d66967f56c7d6b3eb46793f725859. git-svn-id: svn+ssh://svn.gnome.org/svn/empathy/trunk@519 4ee84921-47dd-4033-b63a-18d7a039a3e4
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 8c6094c95..f823d4def 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,3 +1,9 @@
+CLEANFILES=
+
+include $(top_srcdir)/rules/check.mak
+
+SUPPRESSIONS=valgrind.supp dlopen.supp
+
AM_CPPFLAGS = \
-I$(top_srcdir) \
$(EMPATHY_CFLAGS) \
@@ -13,3 +19,22 @@ bin_PROGRAMS = \
contact_manager_SOURCES = contact-manager.c
+check_PROGRAMS = check-main
+TESTS = check-main
+check_main_SOURCES = \
+ check-main.c \
+ check-helpers.c \
+ check-helpers.h \
+ check-libempathy.h \
+ check-empathy-utils.c
+
+check_main_LDADD = \
+ @CHECK_LIBS@ \
+ $(top_builddir)/libempathy-gtk/libempathy-gtk.la \
+ $(top_builddir)/libempathy/libempathy.la \
+ $(AM_LDFLAGS)
+
+check_main_CFLAGS = \
+ @CHECK_CFLAGS@ \
+ $(AM_CFLAGS)
+