aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorGuillaume Desmottes <gdesmott@gnome.org>2009-04-14 18:12:27 +0800
committerGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2009-05-18 17:03:35 +0800
commit4f6d2b1ddf8c1088fccdae24478461cf877a4805 (patch)
tree8dfcfbaf7f49ec383b84a956018d87e22cf96c34 /src/Makefile.am
parent6ef0624346203591e00270f4f595c5f648278547 (diff)
downloadgsoc2013-empathy-4f6d2b1ddf8c1088fccdae24478461cf877a4805.tar
gsoc2013-empathy-4f6d2b1ddf8c1088fccdae24478461cf877a4805.tar.gz
gsoc2013-empathy-4f6d2b1ddf8c1088fccdae24478461cf877a4805.tar.bz2
gsoc2013-empathy-4f6d2b1ddf8c1088fccdae24478461cf877a4805.tar.lz
gsoc2013-empathy-4f6d2b1ddf8c1088fccdae24478461cf877a4805.tar.xz
gsoc2013-empathy-4f6d2b1ddf8c1088fccdae24478461cf877a4805.tar.zst
gsoc2013-empathy-4f6d2b1ddf8c1088fccdae24478461cf877a4805.zip
enable coding style checks in src
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am15
1 files changed, 12 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 9641a1837..58f30ad7d 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -22,8 +22,7 @@ BUILT_SOURCES= \
empathy-tube-dispatch-enumtypes.h \
empathy-tube-dispatch-enumtypes.c
-empathy_SOURCES = \
- bacon-message-connection.c bacon-message-connection.h \
+empathy_handwritten_source = \
empathy.c \
empathy-about-dialog.c empathy-about-dialog.h \
empathy-accounts-dialog.c empathy-accounts-dialog.h \
@@ -41,13 +40,23 @@ empathy_SOURCES = \
empathy-preferences.c empathy-preferences.h \
empathy-sidebar.c empathy-sidebar.h \
empathy-status-icon.c empathy-status-icon.h \
- empathy-tube-dispatch.c empathy-tube-dispatch.h \
+ empathy-tube-dispatch.c empathy-tube-dispatch.h
+
+empathy_SOURCES = \
+ $(empathy_handwritten_source) \
+ bacon-message-connection.c bacon-message-connection.h \
ephy-spinner.c ephy-spinner.h
nodist_empathy_SOURCES = $(BUILT_SOURCES)
empathy_logs_SOURCES = empathy-logs.c
+check_c_sources = \
+ $(empathy_handwritten_source) \
+ $(empathy_logs_SOURCES)
+include $(top_srcdir)/tools/check-coding-style.mk
+check-local: check-coding-style
+
uidir = $(datadir)/empathy
ui_DATA = \
empathy-accounts-dialog.ui \