aboutsummaryrefslogtreecommitdiffstats
path: root/libempathy-gtk/Makefile.am
diff options
context:
space:
mode:
authorEmanuele Aina <emanuele.aina@collabora.com>2013-03-25 23:38:16 +0800
committerMarco Barisione <marco.barisione@collabora.co.uk>2013-08-20 18:03:04 +0800
commit5cbc27ef0f4373175af5725d1a0b78d464bb23b3 (patch)
tree377bc6c4903fc0d159a75d7b5d1facc2f53a7308 /libempathy-gtk/Makefile.am
parent80a78928abd6a5c581e6c0e6036d3e7aea31d7ad (diff)
downloadgsoc2013-empathy-5cbc27ef0f4373175af5725d1a0b78d464bb23b3.tar
gsoc2013-empathy-5cbc27ef0f4373175af5725d1a0b78d464bb23b3.tar.gz
gsoc2013-empathy-5cbc27ef0f4373175af5725d1a0b78d464bb23b3.tar.bz2
gsoc2013-empathy-5cbc27ef0f4373175af5725d1a0b78d464bb23b3.tar.lz
gsoc2013-empathy-5cbc27ef0f4373175af5725d1a0b78d464bb23b3.tar.xz
gsoc2013-empathy-5cbc27ef0f4373175af5725d1a0b78d464bb23b3.tar.zst
gsoc2013-empathy-5cbc27ef0f4373175af5725d1a0b78d464bb23b3.zip
tp-account-widgets: Move account widgets code in the tp-account-widgets subdir
Start moving the account widgets code in a subdir before fully isolating it and stubbing it out in a submodule. https://bugzilla.gnome.org/show_bug.cgi?id=699492
Diffstat (limited to 'libempathy-gtk/Makefile.am')
-rw-r--r--libempathy-gtk/Makefile.am29
1 files changed, 3 insertions, 26 deletions
diff --git a/libempathy-gtk/Makefile.am b/libempathy-gtk/Makefile.am
index 72c27b4b2..3605eea78 100644
--- a/libempathy-gtk/Makefile.am
+++ b/libempathy-gtk/Makefile.am
@@ -4,6 +4,7 @@ include $(top_srcdir)/tools/flymake.mk
AM_CPPFLAGS = \
$(ERROR_CFLAGS) \
+ -I$(top_srcdir)/tp-account-widgets \
-I$(top_srcdir)/libempathy \
-I$(top_srcdir)/extensions \
-DDATADIR=\""$(datadir)"\" \
@@ -22,18 +23,12 @@ AM_CPPFLAGS = \
$(DISABLE_DEPRECATED)
BUILT_SOURCES = \
- empathy-account-widgets-resources.c \
- empathy-account-widgets-resources.h \
empathy-gtk-enum-types.h \
empathy-gtk-enum-types.c
libempathy_gtk_handwritten_source = \
empathy-account-chooser.c \
empathy-account-selector-dialog.c \
- empathy-account-widget-irc.c \
- empathy-account-widget-private.h \
- empathy-account-widget-sip.c \
- empathy-account-widget.c \
empathy-avatar-chooser.c \
empathy-avatar-image.c \
empathy-bad-password-dialog.c \
@@ -64,9 +59,6 @@ libempathy_gtk_handwritten_source = \
empathy-individual-view.c \
empathy-individual-widget.c \
empathy-input-text-view.c \
- empathy-irc-network-chooser.c \
- empathy-irc-network-chooser-dialog.c \
- empathy-irc-network-dialog.c \
empathy-local-xmpp-assistant-widget.c \
empathy-log-window.c \
empathy-new-account-dialog.c \
@@ -102,9 +94,6 @@ libempathy_gtk_handwritten_source = \
libempathy_gtk_headers = \
empathy-account-chooser.h \
empathy-account-selector-dialog.h \
- empathy-account-widget-irc.h \
- empathy-account-widget-sip.h \
- empathy-account-widget.h \
empathy-avatar-chooser.h \
empathy-avatar-image.h \
empathy-bad-password-dialog.h \
@@ -136,9 +125,6 @@ libempathy_gtk_headers = \
empathy-individual-view.h \
empathy-individual-widget.h \
empathy-input-text-view.h \
- empathy-irc-network-chooser.h \
- empathy-irc-network-chooser-dialog.h \
- empathy-irc-network-dialog.h \
empathy-local-xmpp-assistant-widget.h \
empathy-log-window.h \
empathy-new-account-dialog.h \
@@ -183,7 +169,7 @@ libempathy_gtk_la_LDFLAGS = \
libempathy_gtk_la_SOURCES = \
$(libempathy_gtk_handwritten_source) \
$(libempathy_gtk_headers) \
- totem-subtitle-encoding.c totem-subtitle-encoding.h
+ $(NULL)
# do not distribute generated files
nodist_libempathy_gtk_la_SOURCES =\
@@ -202,6 +188,7 @@ libempathy_gtk_la_LIBADD = \
$(GCR_LIBS) \
$(MEEGO_LIBS) \
$(CHEESE_LIBS) \
+ $(top_builddir)/tp-account-widgets/libtp-account-widgets.la \
$(top_builddir)/libempathy-gtk/egg-list-box/libegglistbox.la \
$(top_builddir)/libempathy/libempathy.la
@@ -272,17 +259,7 @@ empathy-gtk-enum-types.c: Makefile $(libempathy_gtk_headers)
&& cp xgen-gtc $(@F) \
&& rm -f xgen-gtc
-account_widgets_resource_files = $(shell $(GLIB_COMPILE_RESOURCES) --generate-dependencies --sourcedir=$(srcdir) $(srcdir)/empathy-account-widgets.gresource.xml)
-
-empathy-account-widgets-resources.c: empathy-account-widgets.gresource.xml $(account_widgets_resource_files)
- $(AM_V_GEN)$(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=$(srcdir) --generate-source $<
-
-empathy-account-widgets-resources.h: empathy-account-widgets.gresource.xml $(account_widgets_resource_files)
- $(AM_V_GEN)$(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=$(srcdir) --generate-header $<
-
EXTRA_DIST = \
- empathy-account-widgets.gresource.xml \
- $(account_widgets_ui_files) \
$(ui_DATA)
if HAVE_GEOCLUE