aboutsummaryrefslogtreecommitdiffstats
path: root/libempathy-gtk/Makefile.am
diff options
context:
space:
mode:
authorGuillaume Desmottes <gdesmott@gnome.org>2009-04-14 18:12:40 +0800
committerGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2009-05-18 23:07:18 +0800
commit5b343bef5aabeedfc6c5fac73eb56519f93ba74f (patch)
tree1c80e407882d80d60ebdf2de7eb37b6a69c30fb8 /libempathy-gtk/Makefile.am
parenta0096d54af2c7b9a33610ac479de36683827780d (diff)
downloadgsoc2013-empathy-5b343bef5aabeedfc6c5fac73eb56519f93ba74f.tar
gsoc2013-empathy-5b343bef5aabeedfc6c5fac73eb56519f93ba74f.tar.gz
gsoc2013-empathy-5b343bef5aabeedfc6c5fac73eb56519f93ba74f.tar.bz2
gsoc2013-empathy-5b343bef5aabeedfc6c5fac73eb56519f93ba74f.tar.lz
gsoc2013-empathy-5b343bef5aabeedfc6c5fac73eb56519f93ba74f.tar.xz
gsoc2013-empathy-5b343bef5aabeedfc6c5fac73eb56519f93ba74f.tar.zst
gsoc2013-empathy-5b343bef5aabeedfc6c5fac73eb56519f93ba74f.zip
enable coding style checks in libempathy-gtk
Diffstat (limited to 'libempathy-gtk/Makefile.am')
-rw-r--r--libempathy-gtk/Makefile.am13
1 files changed, 11 insertions, 2 deletions
diff --git a/libempathy-gtk/Makefile.am b/libempathy-gtk/Makefile.am
index 210b6d4b0..cf6a2762f 100644
--- a/libempathy-gtk/Makefile.am
+++ b/libempathy-gtk/Makefile.am
@@ -19,7 +19,7 @@ BUILT_SOURCES = \
lib_LTLIBRARIES = libempathy-gtk.la
-libempathy_gtk_la_SOURCES = \
+libempathy_gtk_handwritten_source = \
empathy-account-chooser.c \
empathy-account-widget.c \
empathy-account-widget-irc.c \
@@ -55,7 +55,10 @@ libempathy_gtk_la_SOURCES = \
empathy-theme-boxes.c \
empathy-theme-irc.c \
empathy-theme-manager.c \
- empathy-ui-utils.c \
+ empathy-ui-utils.c
+
+libempathy_gtk_la_SOURCES = \
+ $(libempathy_gtk_handwritten_source) \
totem-subtitle-encoding.c totem-subtitle-encoding.h
# do not distribute generated files
@@ -110,6 +113,12 @@ libempathy_gtk_headers = \
empathy-theme-manager.h \
empathy-ui-utils.h
+check_c_sources = \
+ $(libempathy_gtk_handwritten_source) \
+ $(libempathy_gtk_headers)
+include $(top_srcdir)/tools/check-coding-style.mk
+check-local: check-coding-style
+
libempathy_gtk_includedir = $(includedir)/libempathy-gtk/
libempathy_gtk_include_HEADERS = \
$(libempathy_gtk_headers) \