aboutsummaryrefslogtreecommitdiffstats
path: root/gnome-2-26/Makefile.am
diff options
context:
space:
mode:
authorXavier Claessens <xclaesse@src.gnome.org>2009-03-17 02:34:54 +0800
committerXavier Claessens <xclaesse@src.gnome.org>2009-03-17 02:34:54 +0800
commit2baaa7ae3c3ac983a8019cd93a73426c7e081735 (patch)
tree482c49b5b4f5b3d6b4427642ba8609114503fade /gnome-2-26/Makefile.am
parentbbacde3ff32a1983e7f37eea2986ccfe8f660f3f (diff)
downloadgsoc2013-empathy-2baaa7ae3c3ac983a8019cd93a73426c7e081735.tar
gsoc2013-empathy-2baaa7ae3c3ac983a8019cd93a73426c7e081735.tar.gz
gsoc2013-empathy-2baaa7ae3c3ac983a8019cd93a73426c7e081735.tar.bz2
gsoc2013-empathy-2baaa7ae3c3ac983a8019cd93a73426c7e081735.tar.lz
gsoc2013-empathy-2baaa7ae3c3ac983a8019cd93a73426c7e081735.tar.xz
gsoc2013-empathy-2baaa7ae3c3ac983a8019cd93a73426c7e081735.tar.zst
gsoc2013-empathy-2baaa7ae3c3ac983a8019cd93a73426c7e081735.zip
Tagged for release 2.26.0.
svn path=/tags/EMPATHY_2_26_0/; revision=2700
Diffstat (limited to 'gnome-2-26/Makefile.am')
-rw-r--r--gnome-2-26/Makefile.am47
1 files changed, 47 insertions, 0 deletions
diff --git a/gnome-2-26/Makefile.am b/gnome-2-26/Makefile.am
new file mode 100644
index 000000000..479294621
--- /dev/null
+++ b/gnome-2-26/Makefile.am
@@ -0,0 +1,47 @@
+SUBDIRS = tools extensions po data libempathy libempathy-gtk src docs help
+
+if HAVE_MEGAPHONE
+SUBDIRS += megaphone
+endif
+
+if HAVE_NOTHERE
+SUBDIRS += nothere
+endif
+
+if HAVE_PYTHON
+SUBDIRS += python
+endif
+
+if HAVE_TESTS
+SUBDIRS += tests
+endif
+
+ACLOCAL_AMFLAGS = -I m4
+
+DISTCHECK_CONFIGURE_FLAGS = \
+ --disable-scrollkeeper \
+ --disable-schemas-install \
+ --enable-gtk-doc
+
+EXTRA_DIST = \
+ ChangeLog \
+ ChangeLog.old \
+ README \
+ CONTRIBUTORS \
+ autogen.sh
+
+DISTCLEANFILES = \
+ ChangeLog
+
+# Workaround broken scrollkeeper that doesn't remove its files on
+# uninstall.
+distuninstallcheck_listfiles = find . -type f -print | grep -v '^\./var/scrollkeeper'
+
+ChangeLog: Makefile.am
+ git log --pretty=short > ChangeLog
+
+
+dist: ChangeLog
+
+.PHONY: ChangeLog
+