aboutsummaryrefslogtreecommitdiffstats
path: root/extensions/Makefile.am
diff options
context:
space:
mode:
authorDebarshi Ray <debarshir@src.gnome.org>2012-12-01 02:29:13 +0800
committerDebarshi Ray <debarshir@src.gnome.org>2012-12-01 02:47:05 +0800
commitf1ab42c0c5332e47b33ecf905afd7fd6c2a344e8 (patch)
treeee378435fb80eb61dcf479740cfa74529673dd60 /extensions/Makefile.am
parent20119b254b286ee19320687bebd9483cbb5cdb29 (diff)
downloadgsoc2013-empathy-f1ab42c0c5332e47b33ecf905afd7fd6c2a344e8.tar
gsoc2013-empathy-f1ab42c0c5332e47b33ecf905afd7fd6c2a344e8.tar.gz
gsoc2013-empathy-f1ab42c0c5332e47b33ecf905afd7fd6c2a344e8.tar.bz2
gsoc2013-empathy-f1ab42c0c5332e47b33ecf905afd7fd6c2a344e8.tar.lz
gsoc2013-empathy-f1ab42c0c5332e47b33ecf905afd7fd6c2a344e8.tar.xz
gsoc2013-empathy-f1ab42c0c5332e47b33ecf905afd7fd6c2a344e8.tar.zst
gsoc2013-empathy-f1ab42c0c5332e47b33ecf905afd7fd6c2a344e8.zip
Make parallel builds work
There is no need to execute glib-ginterface-gen.py twice because it generates both the .c and .h files in one shot. Therefore, merely having one of them (say the .c) depend on the other (say the .h) is enough. Moreover, running it twice breaks parallel builds because one glib-ginterface-gen.py process steps on the other. Based on a suggestion from Ryan Lortie. Fixes: https://bugzilla.gnome.org/688132
Diffstat (limited to 'extensions/Makefile.am')
-rw-r--r--extensions/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/extensions/Makefile.am b/extensions/Makefile.am
index bc4213309..65f2f5e01 100644
--- a/extensions/Makefile.am
+++ b/extensions/Makefile.am
@@ -108,7 +108,17 @@ _gen/cli-misc-body.h _gen/cli-misc.h: _gen/misc.xml \
--tp-proxy-api=0.10.0 \
$< Emp_Cli _gen/cli-misc
-_gen/svc-misc.c _gen/svc-misc.h: _gen/misc.xml \
+# There is no need to execute glib-ginterface-gen.py twice because it
+# generates both the .c and .h files in one shot. Therefore, merely
+# having one of them (say the .c) depend on the other (say the .h) is
+# enough.
+#
+# Moreover, running it twice breaks parallel builds because one
+# glib-ginterface-gen.py process steps on the other.
+
+_gen/svc-misc.c: _gen/svc-misc.h
+
+_gen/svc-misc.h: _gen/misc.xml \
$(tools_dir)/glib-ginterface-gen.py
$(AM_V_GEN)$(PYTHON) $(tools_dir)/glib-ginterface-gen.py \
--filename=_gen/svc-misc \