aboutsummaryrefslogtreecommitdiffstats
path: root/doc/libempathy-gtk/Makefile.am
diff options
context:
space:
mode:
authorXavier Claessens <xclaesse@gmail.com>2007-11-16 01:25:13 +0800
committerXavier Claessens <xclaesse@src.gnome.org>2007-11-16 01:25:13 +0800
commit1b97222821b7362cce1a68d6ba54106c66f5b932 (patch)
tree03d841fdb3e8af93f0c5ab9cc07392be8d05de55 /doc/libempathy-gtk/Makefile.am
parentc9721056606b7d03de34eabcf8ad17acac52cab3 (diff)
downloadgsoc2013-empathy-1b97222821b7362cce1a68d6ba54106c66f5b932.tar
gsoc2013-empathy-1b97222821b7362cce1a68d6ba54106c66f5b932.tar.gz
gsoc2013-empathy-1b97222821b7362cce1a68d6ba54106c66f5b932.tar.bz2
gsoc2013-empathy-1b97222821b7362cce1a68d6ba54106c66f5b932.tar.lz
gsoc2013-empathy-1b97222821b7362cce1a68d6ba54106c66f5b932.tar.xz
gsoc2013-empathy-1b97222821b7362cce1a68d6ba54106c66f5b932.tar.zst
gsoc2013-empathy-1b97222821b7362cce1a68d6ba54106c66f5b932.zip
Remove doc directory and replace it with a better gtk-doc in docs. More
2007-11-15 Xavier Claessens <xclaesse@gmail.com> * docs/*: * doc/*: * configure.ac: * Makefile.am: Remove doc directory and replace it with a better gtk-doc in docs. More files are auto-generated, we have less files on SVN. svn path=/trunk/; revision=439
Diffstat (limited to 'doc/libempathy-gtk/Makefile.am')
-rw-r--r--doc/libempathy-gtk/Makefile.am69
1 files changed, 0 insertions, 69 deletions
diff --git a/doc/libempathy-gtk/Makefile.am b/doc/libempathy-gtk/Makefile.am
deleted file mode 100644
index 925daf5c1..000000000
--- a/doc/libempathy-gtk/Makefile.am
+++ /dev/null
@@ -1,69 +0,0 @@
-## Process this file with automake to produce Makefile.in
-
-# We require automake 1.6 at least.
-AUTOMAKE_OPTIONS = 1.9
-
-# This is a blank Makefile.am for using gtk-doc.
-# Copy this to your project's API docs directory and modify the variables to
-# suit your project. See the GTK+ Makefiles in gtk+/docs/reference for examples
-# of using the various options.
-
-# The name of the module, e.g. 'glib'.
-DOC_MODULE=libempathy-gtk
-
-# The top-level SGML file. You can change this if you want to.
-DOC_MAIN_SGML_FILE=$(DOC_MODULE)-docs.sgml
-
-# The directory containing the source code. Relative to $(srcdir).
-# gtk-doc will search all .c & .h files beneath here for inline comments
-# documenting the functions and macros.
-# e.g. DOC_SOURCE_DIR=../../../gtk
-DOC_SOURCE_DIR=../../libempathy-gtk
-
-# Extra options to pass to gtkdoc-scangobj. Not normally needed.
-SCANGOBJ_OPTIONS=
-
-# Extra options to supply to gtkdoc-scan.
-# e.g. SCAN_OPTIONS=--deprecated-guards="GTK_DISABLE_DEPRECATED"
-SCAN_OPTIONS=
-
-# Extra options to supply to gtkdoc-mkdb.
-# e.g. MKDB_OPTIONS=--sgml-mode --output-format=xml
-MKDB_OPTIONS=--sgml-mode --output-format=xml
-
-# Extra options to supply to gtkdoc-fixref. Not normally needed.
-# e.g. FIXXREF_OPTIONS=--extra-dir=../gdk-pixbuf/html --extra-dir=../gdk/html
-FIXXREF_OPTIONS=
-
-# Used for dependencies. The docs will be rebuilt if any of these change.
-# e.g. HFILE_GLOB=$(top_srcdir)/gtk/*.h
-# e.g. CFILE_GLOB=$(top_srcdir)/gtk/*.c
-HFILE_GLOB=$(top_srcdir)/libempathy-gtk/*.h
-CFILE_GLOB=$(top_srcdir)/libempathy-gtk/*.c
-
-# Header files to ignore when scanning.
-# e.g. IGNORE_HFILES=gtkdebug.h gtkintl.h
-IGNORE_HFILES=
-
-# Images to copy into HTML directory.
-# e.g. HTML_IMAGES=$(top_srcdir)/gtk/stock-icons/stock_about_24.png
-HTML_IMAGES=
-
-# Extra SGML files that are included by $(DOC_MAIN_SGML_FILE).
-# e.g. content_files=running.sgml building.sgml changes-2.0.sgml
-content_files=
-
-# CFLAGS and LDFLAGS for compiling gtkdoc-scangobj with your library.
-# Only needed if you are using gtkdoc-scangobj to dynamically query widget
-# signals and properties.
-# e.g. INCLUDES=-I$(top_srcdir) -I$(top_builddir) $(GTK_DEBUG_FLAGS)
-# e.g. GTKDOC_LIBS=$(top_builddir)/gtk/$(gtktargetlib)
-INCLUDES=-I$(top_srcdir) $(EMPATHY_CFLAGS)
-GTKDOC_LIBS=$(top_builddir)/libempathy-gtk/libempathy-gtk.la $(top_builddir)/libempathy/libempathy.la $(EMPATHY_LIBS)
-
-# This includes the standard gtk-doc make rules, copied by gtkdocize.
-include $(top_srcdir)/gtk-doc.make
-
-# Other files to distribute
-# e.g. EXTRA_DIST += version.xml.in
-EXTRA_DIST +=