aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorFrederic Peters <fpeters@src.gnome.org>2008-10-06 17:14:33 +0800
committerFrederic Peters <fpeters@src.gnome.org>2008-10-06 17:14:33 +0800
commitd935950af0cbc80ad209a1aad34a3846a2be8839 (patch)
tree847f00db310a2678269880a619f4672365eb7be3 /configure.ac
parent18d7a4e519b72035909b18862b49d23310d2fcd6 (diff)
downloadgsoc2013-empathy-d935950af0cbc80ad209a1aad34a3846a2be8839.tar
gsoc2013-empathy-d935950af0cbc80ad209a1aad34a3846a2be8839.tar.gz
gsoc2013-empathy-d935950af0cbc80ad209a1aad34a3846a2be8839.tar.bz2
gsoc2013-empathy-d935950af0cbc80ad209a1aad34a3846a2be8839.tar.lz
gsoc2013-empathy-d935950af0cbc80ad209a1aad34a3846a2be8839.tar.xz
gsoc2013-empathy-d935950af0cbc80ad209a1aad34a3846a2be8839.tar.zst
gsoc2013-empathy-d935950af0cbc80ad209a1aad34a3846a2be8839.zip
use AM_PATH_PYTHON for Python detection (closes: #544029)
svn path=/branches/gnome-2-24/; revision=1523
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac38
1 files changed, 15 insertions, 23 deletions
diff --git a/configure.ac b/configure.ac
index 01acdb613..5f8db6f6c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -69,10 +69,7 @@ AC_CHECK_PROGS([XSLTPROC], [xsltproc])
if test -z "$XSLTPROC"; then
AC_MSG_ERROR([xsltproc (from libxslt) is required])
fi
-AC_CHECK_PROGS([PYTHON], [python python2.3 python2.4 python2.5])
-if test -z "$PYTHON"; then
- AC_MSG_ERROR([Python is required])
-fi
+AM_PATH_PYTHON([2.3])
EMPATHY_ARG_VALGRIND
@@ -251,25 +248,20 @@ AC_ARG_ENABLE(python,
enable_python=auto)
if test "x$enable_python" != "xno"; then
- AM_PATH_PYTHON
- if test -z "$PYTHON" ; then
- have_python="no"
- else
- PKG_CHECK_MODULES(PYTHON_BINDING,
- [
- pygtk-2.0,
- glib-2.0 >= $GLIB_REQUIRED
- gobject-2.0
- gconf-2.0 >= $GCONF_REQUIRED
- libxml-2.0
- libmissioncontrol >= $MISSION_CONTROL_REQUIRED
- gtk+-2.0 >= $GTK_REQUIRED
- libglade-2.0 >= $LIBGLADE_REQUIRED
- ], have_python="yes", have_python="no")
- if test "x$have_python" = "xyes" ; then
- AM_CHECK_PYTHON_HEADERS(,have_python="no")
- AC_CHECK_PROGS([PYGOBJECTCODEGEN], [pygobject-codegen-2.0 pygtk-codegen-2.0])
- fi
+ PKG_CHECK_MODULES(PYTHON_BINDING,
+ [
+ pygtk-2.0,
+ glib-2.0 >= $GLIB_REQUIRED
+ gobject-2.0
+ gconf-2.0 >= $GCONF_REQUIRED
+ libxml-2.0
+ libmissioncontrol >= $MISSION_CONTROL_REQUIRED
+ gtk+-2.0 >= $GTK_REQUIRED
+ libglade-2.0 >= $LIBGLADE_REQUIRED
+ ], have_python="yes", have_python="no")
+ if test "x$have_python" = "xyes" ; then
+ AM_CHECK_PYTHON_HEADERS(,have_python="no")
+ AC_CHECK_PROGS([PYGOBJECTCODEGEN], [pygobject-codegen-2.0 pygtk-codegen-2.0])
fi
else
have_python=no