aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorXavier Claessens <xclaesse@gmail.com>2007-09-21 20:24:24 +0800
committerXavier Claessens <xclaesse@src.gnome.org>2007-09-21 20:24:24 +0800
commitc657583832cbf675516a105c1f7bbc6bebea6e34 (patch)
tree01e1aca50b42a38943ae09f8fd327aba2f8af118 /configure.ac
parent004e5e331b89484f2448ab81d0e97cfc3b47af18 (diff)
downloadgsoc2013-empathy-c657583832cbf675516a105c1f7bbc6bebea6e34.tar
gsoc2013-empathy-c657583832cbf675516a105c1f7bbc6bebea6e34.tar.gz
gsoc2013-empathy-c657583832cbf675516a105c1f7bbc6bebea6e34.tar.bz2
gsoc2013-empathy-c657583832cbf675516a105c1f7bbc6bebea6e34.tar.lz
gsoc2013-empathy-c657583832cbf675516a105c1f7bbc6bebea6e34.tar.xz
gsoc2013-empathy-c657583832cbf675516a105c1f7bbc6bebea6e34.tar.zst
gsoc2013-empathy-c657583832cbf675516a105c1f7bbc6bebea6e34.zip
Fix warnings when finalizing.
2007-09-21 Xavier Claessens <xclaesse@gmail.com> * libempathy/empathy-tp-contact-list.c: Fix warnings when finalizing. * tests/contact-manager.c: * tests/Makefile.am: * configure.ac: * Makefile.am: Add a test program to track leaks. svn path=/trunk/; revision=304
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a3e865f28..bade8bb30 100644
--- a/configure.ac
+++ b/configure.ac
@@ -205,6 +205,16 @@ fi
AM_CONDITIONAL(HAVE_NOTHERE, test "x$have_nothere" = "xyes")
dnl -----------------------------------------------------------
+dnl Tests
+dnl -----------------------------------------------------------
+AC_ARG_ENABLE(tests,
+ AS_HELP_STRING([--enable-tests=@<:@no/yes@:>@],
+ [build tests]), ,
+ enable_tests=no)
+
+AM_CONDITIONAL(HAVE_TESTS, test "x$enable_tests" = "xyes")
+
+dnl -----------------------------------------------------------
dnl Python Bindings
dnl -----------------------------------------------------------
AC_ARG_ENABLE(python,
@@ -271,4 +281,5 @@ AC_OUTPUT([
python/Makefile
python/pyempathy/Makefile
python/pyempathygtk/Makefile
+ tests/Makefile
])