aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDanielle Madeley <danielle.madeley@collabora.co.uk>2011-08-16 11:38:23 +0800
committerDanielle Madeley <danielle.madeley@collabora.co.uk>2011-08-16 11:38:23 +0800
commit6cf57d879945059cd974a3ee6d02d81edff47438 (patch)
tree04ba16a72ba34bfa0b4cee7788c2db2b5a70a43e /configure.ac
parentd5024011258a052ea3b88e95d0098f3901bb98cc (diff)
downloadgsoc2013-empathy-6cf57d879945059cd974a3ee6d02d81edff47438.tar
gsoc2013-empathy-6cf57d879945059cd974a3ee6d02d81edff47438.tar.gz
gsoc2013-empathy-6cf57d879945059cd974a3ee6d02d81edff47438.tar.bz2
gsoc2013-empathy-6cf57d879945059cd974a3ee6d02d81edff47438.tar.lz
gsoc2013-empathy-6cf57d879945059cd974a3ee6d02d81edff47438.tar.xz
gsoc2013-empathy-6cf57d879945059cd974a3ee6d02d81edff47438.tar.zst
gsoc2013-empathy-6cf57d879945059cd974a3ee6d02d81edff47438.zip
Make WebKit compulsory
It is now required for the log viewer, furthermore it will be required once we remove non-adium themes.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac28
1 files changed, 2 insertions, 26 deletions
diff --git a/configure.ac b/configure.ac
index 29873caab..7f6ec16dd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -43,6 +43,7 @@ LIBNOTIFY_REQUIRED=0.7.0
TELEPATHY_FARSIGHT_REQUIRED=0.0.14
TELEPATHY_GLIB_REQUIRED=0.15.3
TELEPATHY_LOGGER=0.2.10
+WEBKIT_REQUIRED=1.3.13
# Optional deps
CLUTTER_GTK_REQUIRED=0.90.3
@@ -53,7 +54,6 @@ LIBCHAMPLAIN_GTK_REQUIRED=0.7.1
LIBCHAMPLAIN_REQUIRED=0.9
NAUTILUS_SENDTO_REQUIRED=2.90.0
NETWORK_MANAGER_REQUIRED=0.7.0
-WEBKIT_REQUIRED=1.3.13
GNOME_CONTROL_CENTER_REQUIRED=2.31.4
# Use --enable-maintainer-mode to disable deprecated symbols,
@@ -174,6 +174,7 @@ PKG_CHECK_MODULES(EMPATHY,
libcanberra-gtk3 >= $LIBCANBERRA_GTK_REQUIRED
libnotify >= $LIBNOTIFY_REQUIRED
gcr-3 >= $GCR_REQUIRED
+ webkitgtk-3.0 >= $WEBKIT_REQUIRED
])
PKG_CHECK_MODULES(YELL, [telepathy-yell])
@@ -327,30 +328,6 @@ AM_CONDITIONAL(HAVE_NM, test "x$have_nm" = "xyes")
AM_CONDITIONAL(HAVE_CONNMAN, test "x$have_connman" = "xyes")
# -----------------------------------------------------------
-# Webkit
-# -----------------------------------------------------------
-AC_ARG_ENABLE(webkit,
- AS_HELP_STRING([--enable-webkit=@<:@no/yes/auto@:>@],
- [build with webkit support]), ,
- enable_webkit=auto)
-
-if test "x$enable_webkit" != "xno"; then
- PKG_CHECK_MODULES(WEBKIT, [webkitgtk-3.0 >= $WEBKIT_REQUIRED],
- have_webkit="yes", have_webkit="no")
-
- if test "x$have_webkit" = "xyes"; then
- AC_DEFINE(HAVE_WEBKIT, 1, [Define if you have libwebkitgtk])
- fi
-else
- have_webkit=no
-fi
-
-if test "x$enable_webkit" = "xyes" -a "x$have_webkit" != "xyes"; then
- AC_MSG_ERROR([Could not find webkit dependencies.])
-fi
-AM_CONDITIONAL(HAVE_WEBKIT, test "x$have_webkit" = "xyes")
-
-# -----------------------------------------------------------
# gudev
# -----------------------------------------------------------
AC_ARG_ENABLE(gudev,
@@ -653,7 +630,6 @@ Configure summary:
Display maps (libchamplain).: ${have_libchamplain}
Location awareness (Geoclue): ${have_geoclue}
Geocode support (Geoclue)...: ${have_geocode}
- Adium themes (Webkit).......: ${have_webkit}
Meego widgets...............: ${have_meego}
Control center embedding....: ${have_control_center_embedding}
Cheese webcam support ......: ${have_cheese}