aboutsummaryrefslogtreecommitdiffstats
path: root/lllc/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lllc/CMakeLists.txt')
-rw-r--r--lllc/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/lllc/CMakeLists.txt b/lllc/CMakeLists.txt
new file mode 100644
index 00000000..3a5b9c55
--- /dev/null
+++ b/lllc/CMakeLists.txt
@@ -0,0 +1,11 @@
+aux_source_directory(. SRC_LIST)
+
+set(EXECUTABLE lllc)
+
+file(GLOB HEADERS "*.h")
+add_executable(${EXECUTABLE} ${SRC_LIST} ${HEADERS})
+
+eth_use(${EXECUTABLE} REQUIRED Eth::lll Dev::buildinfo)
+
+install( TARGETS ${EXECUTABLE} DESTINATION bin )
+