aboutsummaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorPaweł Bylica <chfast@gmail.com>2017-08-17 21:48:39 +0800
committerPaweł Bylica <chfast@gmail.com>2017-08-21 18:27:06 +0800
commit99d198ffb034839e82649f10814210c0374d40d4 (patch)
tree41b5b05cec5b239bc494527be2044ff1ea7e1f41 /test/CMakeLists.txt
parent0712e6302e728bba281f41afa74e6c74638a75c7 (diff)
downloaddexon-solidity-99d198ffb034839e82649f10814210c0374d40d4.tar
dexon-solidity-99d198ffb034839e82649f10814210c0374d40d4.tar.gz
dexon-solidity-99d198ffb034839e82649f10814210c0374d40d4.tar.bz2
dexon-solidity-99d198ffb034839e82649f10814210c0374d40d4.tar.lz
dexon-solidity-99d198ffb034839e82649f10814210c0374d40d4.tar.xz
dexon-solidity-99d198ffb034839e82649f10814210c0374d40d4.tar.zst
dexon-solidity-99d198ffb034839e82649f10814210c0374d40d4.zip
CMake: Make libs dependencies explicit
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 92218f1d..6a8a4399 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -3,7 +3,7 @@ list(REMOVE_ITEM sources "${CMAKE_CURRENT_SOURCE_DIR}/fuzzer.cpp")
file(GLOB_RECURSE headers "*.h")
add_executable(soltest ${sources} ${headers})
-target_link_libraries(soltest PRIVATE soljson solidity lll ${Boost_UNIT_TEST_FRAMEWORK_LIBRARIES})
+target_link_libraries(soltest PRIVATE soljson solidity lll evmasm devcore ${Boost_UNIT_TEST_FRAMEWORK_LIBRARIES})
add_executable(solfuzzer fuzzer.cpp)
target_link_libraries(solfuzzer soljson evmasm ${Boost_PROGRAM_OPTIONS_LIBRARIES})