aboutsummaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorBob Summerwill <bob@summerwill.net>2015-12-06 11:15:53 +0800
committerBob Summerwill <bob@summerwill.net>2015-12-06 11:15:53 +0800
commit942666bce9e11e7161f32c29ada13209957306a1 (patch)
tree49ae14e1e6ccf288e19e491d4617c82fb980326d /test/CMakeLists.txt
parent02e4aa94ff7b1389adf6fae76d403050cf81bc72 (diff)
downloaddexon-solidity-942666bce9e11e7161f32c29ada13209957306a1.tar
dexon-solidity-942666bce9e11e7161f32c29ada13209957306a1.tar.gz
dexon-solidity-942666bce9e11e7161f32c29ada13209957306a1.tar.bz2
dexon-solidity-942666bce9e11e7161f32c29ada13209957306a1.tar.lz
dexon-solidity-942666bce9e11e7161f32c29ada13209957306a1.tar.xz
dexon-solidity-942666bce9e11e7161f32c29ada13209957306a1.tar.zst
dexon-solidity-942666bce9e11e7161f32c29ada13209957306a1.zip
Fix a "Solidity::solidity" dependency edge in the CMake file for soltest, which got missed in the previous PR.
This change resolves an inconsistency which was discovered in the automated dependency graph generation. softest was being declared as dependent on the Solidity module, not on just libsolidity, as it should be.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 9c6e2944..c72d31d3 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -44,7 +44,7 @@ file(GLOB HEADERS "*.h")
set(EXECUTABLE soltest)
add_executable(${EXECUTABLE} ${SRC_LIST} ${HEADERS})
-eth_use(${EXECUTABLE} REQUIRED Solidity Eth::ethereum)
+eth_use(${EXECUTABLE} REQUIRED Solidity::solidity Eth::ethereum)
include_directories(BEFORE ..)
target_link_libraries(${EXECUTABLE} ${Boost_UNIT_TEST_FRAMEWORK_LIBRARIES})