aboutsummaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Kirchner <daniel@ekpyron.org>2018-03-12 21:13:19 +0800
committerDaniel Kirchner <daniel@ekpyron.org>2018-03-13 01:40:20 +0800
commit121f87b043d7c3f01c760589edf1bf342d67c634 (patch)
tree117c4f134316c289a928dbd1c00cb976c6fec0aa /test/CMakeLists.txt
parent30443f3a3e8131813dc6c62c2096c5d79f100a86 (diff)
downloaddexon-solidity-121f87b043d7c3f01c760589edf1bf342d67c634.tar
dexon-solidity-121f87b043d7c3f01c760589edf1bf342d67c634.tar.gz
dexon-solidity-121f87b043d7c3f01c760589edf1bf342d67c634.tar.bz2
dexon-solidity-121f87b043d7c3f01c760589edf1bf342d67c634.tar.lz
dexon-solidity-121f87b043d7c3f01c760589edf1bf342d67c634.tar.xz
dexon-solidity-121f87b043d7c3f01c760589edf1bf342d67c634.tar.zst
dexon-solidity-121f87b043d7c3f01c760589edf1bf342d67c634.zip
Move test tools to the subdirectory test/tools and adjust CMakeLists.txt.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt30
1 files changed, 24 insertions, 6 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index f36ad4c5..522856cc 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -1,9 +1,27 @@
-file(GLOB_RECURSE sources "*.cpp")
-list(REMOVE_ITEM sources "${CMAKE_CURRENT_SOURCE_DIR}/fuzzer.cpp")
-file(GLOB_RECURSE headers "*.h")
+file(GLOB sources "*.cpp")
+file(GLOB headers "*.h")
-add_executable(soltest ${sources} ${headers})
+file(GLOB contracts_sources "contracts/*.cpp")
+file(GLOB contracts_headers "contracts/*.h")
+file(GLOB libdevcore_sources "libdevcore/*.cpp")
+file(GLOB libdevcore_headers "libdevcore/*.h")
+file(GLOB libevmasm_sources "libevmasm/*.cpp")
+file(GLOB libevmasm_headers "libevmasm/*.h")
+file(GLOB libjulia_sources "libjulia/*.cpp")
+file(GLOB libjulia_headers "libjulia/*.h")
+file(GLOB liblll_sources "liblll/*.cpp")
+file(GLOB liblll_headers "liblll/*.h")
+file(GLOB libsolidity_sources "libsolidity/*.cpp")
+file(GLOB libsolidity_headers "libsolidity/*.h")
+
+add_executable(soltest ${sources} ${headers}
+ ${contracts_sources} ${contracts_headers}
+ ${libdevcore_sources} ${libdevcore_headers}
+ ${libevmasm_sources} ${libevmasm_headers}
+ ${libjulia_sources} ${libjulia_headers}
+ ${liblll_sources} ${liblll_headers}
+ ${libsolidity_sources} ${libsolidity_headers}
+)
target_link_libraries(soltest PRIVATE libsolc solidity lll evmasm devcore ${Boost_UNIT_TEST_FRAMEWORK_LIBRARIES})
-add_executable(solfuzzer fuzzer.cpp)
-target_link_libraries(solfuzzer PRIVATE libsolc evmasm ${Boost_PROGRAM_OPTIONS_LIBRARIES})
+add_subdirectory(tools)