aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthew Halpern <matt.halpern@consensys.net>2018-01-16 23:16:14 +0800
committerAlex Beregszaszi <alex@rtfs.hu>2018-02-13 18:20:43 +0800
commitda36c82a0a3fd7c1c55b959f5db68260d00a3a94 (patch)
tree31c3a1abeb0ea672bd2eec69f3b6f699308ddc19 /CMakeLists.txt
parentf8810ef9e8891fb198eb213e4b32374d11ae4bbd (diff)
downloaddexon-solidity-da36c82a0a3fd7c1c55b959f5db68260d00a3a94.tar
dexon-solidity-da36c82a0a3fd7c1c55b959f5db68260d00a3a94.tar.gz
dexon-solidity-da36c82a0a3fd7c1c55b959f5db68260d00a3a94.tar.bz2
dexon-solidity-da36c82a0a3fd7c1c55b959f5db68260d00a3a94.tar.lz
dexon-solidity-da36c82a0a3fd7c1c55b959f5db68260d00a3a94.tar.xz
dexon-solidity-da36c82a0a3fd7c1c55b959f5db68260d00a3a94.tar.zst
dexon-solidity-da36c82a0a3fd7c1c55b959f5db68260d00a3a94.zip
Allow lllc to be installed
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8993f372..eafe8d90 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -12,6 +12,8 @@ set(PROJECT_VERSION "0.4.20")
project(solidity VERSION ${PROJECT_VERSION})
option(SOLC_LINK_STATIC "Link solc executable statically on supported platforms" OFF)
+option(LLLC_LINK_STATIC "Link lllc executable statically on supported platforms" OFF)
+option(INSTALL_LLLC "Include lllc executable in installation" ON)
# Setup cccache.
include(EthCcache)