aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorchriseth <chris@ethereum.org>2017-06-08 17:56:14 +0800
committerchriseth <chris@ethereum.org>2017-06-09 19:11:15 +0800
commit9d0691b47ad9f85920f027a05abb367da4e2f339 (patch)
treec8a3abc9ad5931589b82edd90305b037f3cb7b58 /CMakeLists.txt
parent76667fed4f9865c4a3a5a267c469446f8bce1bef (diff)
downloaddexon-solidity-9d0691b47ad9f85920f027a05abb367da4e2f339.tar
dexon-solidity-9d0691b47ad9f85920f027a05abb367da4e2f339.tar.gz
dexon-solidity-9d0691b47ad9f85920f027a05abb367da4e2f339.tar.bz2
dexon-solidity-9d0691b47ad9f85920f027a05abb367da4e2f339.tar.lz
dexon-solidity-9d0691b47ad9f85920f027a05abb367da4e2f339.tar.xz
dexon-solidity-9d0691b47ad9f85920f027a05abb367da4e2f339.tar.zst
dexon-solidity-9d0691b47ad9f85920f027a05abb367da4e2f339.zip
Include license and warranty statement with solc.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e53917cb..2dbc521d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -24,6 +24,10 @@ include(EthExecutableHelper)
# Include utils
include(EthUtils)
+# Create license.h from LICENSE.txt and template
+file(READ ${CMAKE_SOURCE_DIR}/LICENSE.txt LICENSE_TEXT)
+configure_file("${CMAKE_SOURCE_DIR}/cmake/templates/license.h.in" "license.h")
+
include(EthOptions)
configure_project(TESTS)