aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPaweł Bylica <chfast@gmail.com>2017-08-23 04:50:03 +0800
committerPaweł Bylica <chfast@gmail.com>2017-08-23 04:50:25 +0800
commit4974ff3962759a19150877b0e59e64319190ba1d (patch)
treec0a96c8d0037de5ef64c44d33a7683598216970d /CMakeLists.txt
parent15fd43f0357e1f3c6ec1262df6ee39b06a6fe3f9 (diff)
downloaddexon-solidity-4974ff3962759a19150877b0e59e64319190ba1d.tar
dexon-solidity-4974ff3962759a19150877b0e59e64319190ba1d.tar.gz
dexon-solidity-4974ff3962759a19150877b0e59e64319190ba1d.tar.bz2
dexon-solidity-4974ff3962759a19150877b0e59e64319190ba1d.tar.lz
dexon-solidity-4974ff3962759a19150877b0e59e64319190ba1d.tar.xz
dexon-solidity-4974ff3962759a19150877b0e59e64319190ba1d.tar.zst
dexon-solidity-4974ff3962759a19150877b0e59e64319190ba1d.zip
CMake: Add option to static link solc
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d204ffec..da14ddb7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,6 +11,8 @@ eth_policy()
set(PROJECT_VERSION "0.4.16")
project(solidity VERSION ${PROJECT_VERSION})
+option(SOLC_LINK_STATIC "Link solc executable statically on supported platforms" OFF)
+
# Let's find our dependencies
include(EthDependencies)
include(deps/jsoncpp.cmake)