aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorchriseth <chris@ethereum.org>2017-06-14 18:42:48 +0800
committerchriseth <chris@ethereum.org>2017-06-14 18:42:48 +0800
commit1d79059897ae35cc5af87a3afb0d5c05949ab2b3 (patch)
treed55dbffedd5473cb4ab1ea78a6d45039b19cd7c0 /CMakeLists.txt
parentd3f4c97c533b2f64dda9fe7bdf5848f6c8bbb300 (diff)
downloaddexon-solidity-1d79059897ae35cc5af87a3afb0d5c05949ab2b3.tar
dexon-solidity-1d79059897ae35cc5af87a3afb0d5c05949ab2b3.tar.gz
dexon-solidity-1d79059897ae35cc5af87a3afb0d5c05949ab2b3.tar.bz2
dexon-solidity-1d79059897ae35cc5af87a3afb0d5c05949ab2b3.tar.lz
dexon-solidity-1d79059897ae35cc5af87a3afb0d5c05949ab2b3.tar.xz
dexon-solidity-1d79059897ae35cc5af87a3afb0d5c05949ab2b3.tar.zst
dexon-solidity-1d79059897ae35cc5af87a3afb0d5c05949ab2b3.zip
Convert license to character array.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2dbc521d..e0eef4d2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -25,7 +25,11 @@ include(EthExecutableHelper)
include(EthUtils)
# Create license.h from LICENSE.txt and template
-file(READ ${CMAKE_SOURCE_DIR}/LICENSE.txt LICENSE_TEXT)
+# Converting to char array is required due to MSVC's string size limit.
+file(READ ${CMAKE_SOURCE_DIR}/LICENSE.txt LICENSE_TEXT HEX)
+string(REGEX MATCHALL ".." LICENSE_TEXT "${LICENSE_TEXT}")
+string(REGEX REPLACE ";" ",\t0x" LICENSE_TEXT "${LICENSE_TEXT}")
+
configure_file("${CMAKE_SOURCE_DIR}/cmake/templates/license.h.in" "license.h")
include(EthOptions)