aboutsummaryrefslogtreecommitdiffstats
path: root/python-packages/json_schemas/tox.ini
diff options
context:
space:
mode:
Diffstat (limited to 'python-packages/json_schemas/tox.ini')
-rw-r--r--python-packages/json_schemas/tox.ini25
1 files changed, 25 insertions, 0 deletions
diff --git a/python-packages/json_schemas/tox.ini b/python-packages/json_schemas/tox.ini
new file mode 100644
index 000000000..1d5de646e
--- /dev/null
+++ b/python-packages/json_schemas/tox.ini
@@ -0,0 +1,25 @@
+# tox (https://tox.readthedocs.io/) is a tool for running tests
+# in multiple virtualenvs. This configuration file will run the
+# test suite on all supported python versions. To use it, "pip install tox"
+# and then run "tox" from this directory.
+
+[tox]
+envlist = py37
+
+[testenv]
+commands =
+ pip install -e .[dev]
+ python setup.py test
+
+[testenv:run_tests_against_test_deployment]
+commands =
+ # install dependencies from real PyPI
+ pip install jsonschema mypy_extensions pytest
+ # install package-under-test from test PyPI
+ pip install --index-url https://test.pypi.org/legacy/ 0x-json-schemas
+ pytest test
+
+[testenv:run_tests_against_deployment]
+commands =
+ pip install 0x-json-schemas
+ pytest test