aboutsummaryrefslogtreecommitdiffstats
path: root/python-packages/contract_artifacts/README.md
diff options
context:
space:
mode:
Diffstat (limited to 'python-packages/contract_artifacts/README.md')
-rw-r--r--python-packages/contract_artifacts/README.md39
1 files changed, 39 insertions, 0 deletions
diff --git a/python-packages/contract_artifacts/README.md b/python-packages/contract_artifacts/README.md
new file mode 100644
index 000000000..caa6b5df4
--- /dev/null
+++ b/python-packages/contract_artifacts/README.md
@@ -0,0 +1,39 @@
+## 0x-contract-artifacts
+
+0x smart contract compilation artifacts
+
+Read the [documentation](http://0x-contract-artifacts-py.s3-website-us-east-1.amazonaws.com/)
+
+## Installing
+
+```bash
+pip install 0x-contract-artifacts
+```
+
+## Contributing
+
+We welcome improvements and fixes from the wider community! To report bugs within this package, please create an issue in this repository.
+
+Please read our [contribution guidelines](../../CONTRIBUTING.md) before getting started.
+
+### Install Code and Dependencies
+
+```bash
+pip install -e .[dev]
+```
+
+### Clean
+
+`./setup.py clean --all`
+
+### Lint
+
+`./setup.py lint`
+
+### Build Documentation
+
+`./setup.py build_sphinx`
+
+### More
+
+See `./setup.py --help-commands` for more info.