aboutsummaryrefslogtreecommitdiffstats
path: root/python-packages/sra_client/setup.py
diff options
context:
space:
mode:
authorSteve Klebanoff <steve.klebanoff@gmail.com>2019-01-10 00:54:55 +0800
committerSteve Klebanoff <steve.klebanoff@gmail.com>2019-01-10 00:54:55 +0800
commitfb3605026ef63ef6897010a52bf3f4c116cdf271 (patch)
treeaf3887e5f785e049daeaf795e0f3e4a9ad370d93 /python-packages/sra_client/setup.py
parent76dde294f10bb3d5c1074cd6599668bcb1cdd8ec (diff)
parent5b8c9122a292f6558c45440b053ceae52d36d495 (diff)
downloaddexon-0x-contracts-fb3605026ef63ef6897010a52bf3f4c116cdf271.tar
dexon-0x-contracts-fb3605026ef63ef6897010a52bf3f4c116cdf271.tar.gz
dexon-0x-contracts-fb3605026ef63ef6897010a52bf3f4c116cdf271.tar.bz2
dexon-0x-contracts-fb3605026ef63ef6897010a52bf3f4c116cdf271.tar.lz
dexon-0x-contracts-fb3605026ef63ef6897010a52bf3f4c116cdf271.tar.xz
dexon-0x-contracts-fb3605026ef63ef6897010a52bf3f4c116cdf271.tar.zst
dexon-0x-contracts-fb3605026ef63ef6897010a52bf3f4c116cdf271.zip
Merge branch 'development' into feature/instant/tell-amount-available
Diffstat (limited to 'python-packages/sra_client/setup.py')
-rwxr-xr-xpython-packages/sra_client/setup.py10
1 files changed, 10 insertions, 0 deletions
diff --git a/python-packages/sra_client/setup.py b/python-packages/sra_client/setup.py
index b47f71ae7..0921149bd 100755
--- a/python-packages/sra_client/setup.py
+++ b/python-packages/sra_client/setup.py
@@ -48,6 +48,15 @@ class PublishCommand(distutils.command.build_py.build_py):
subprocess.check_call("twine upload dist/*".split()) # nosec
+class LintCommand(distutils.command.build_py.build_py):
+ """No-op lint command to support top-level lint script."""
+
+ description = "No-op"
+
+ def run(self):
+ pass
+
+
setup(
name=NAME,
version=VERSION,
@@ -63,5 +72,6 @@ setup(
cmdclass={
"test_publish": TestPublishCommand,
"publish": PublishCommand,
+ "lint": LintCommand,
},
)