aboutsummaryrefslogtreecommitdiffstats
path: root/python-packages/contract_demo/README.md
diff options
context:
space:
mode:
authorSteve Klebanoff <steve.klebanoff@gmail.com>2019-01-10 00:54:55 +0800
committerSteve Klebanoff <steve.klebanoff@gmail.com>2019-01-10 00:54:55 +0800
commitfb3605026ef63ef6897010a52bf3f4c116cdf271 (patch)
treeaf3887e5f785e049daeaf795e0f3e4a9ad370d93 /python-packages/contract_demo/README.md
parent76dde294f10bb3d5c1074cd6599668bcb1cdd8ec (diff)
parent5b8c9122a292f6558c45440b053ceae52d36d495 (diff)
downloaddexon-0x-contracts-fb3605026ef63ef6897010a52bf3f4c116cdf271.tar
dexon-0x-contracts-fb3605026ef63ef6897010a52bf3f4c116cdf271.tar.gz
dexon-0x-contracts-fb3605026ef63ef6897010a52bf3f4c116cdf271.tar.bz2
dexon-0x-contracts-fb3605026ef63ef6897010a52bf3f4c116cdf271.tar.lz
dexon-0x-contracts-fb3605026ef63ef6897010a52bf3f4c116cdf271.tar.xz
dexon-0x-contracts-fb3605026ef63ef6897010a52bf3f4c116cdf271.tar.zst
dexon-0x-contracts-fb3605026ef63ef6897010a52bf3f4c116cdf271.zip
Merge branch 'development' into feature/instant/tell-amount-available
Diffstat (limited to 'python-packages/contract_demo/README.md')
-rw-r--r--python-packages/contract_demo/README.md39
1 files changed, 39 insertions, 0 deletions
diff --git a/python-packages/contract_demo/README.md b/python-packages/contract_demo/README.md
new file mode 100644
index 000000000..3a0f964e3
--- /dev/null
+++ b/python-packages/contract_demo/README.md
@@ -0,0 +1,39 @@
+## 0x-contract-demo
+
+A demonstration of calling 0x smart contracts from Python.
+
+Read the [documentation](http://0x-contract-demo-py.s3-website-us-east-1.amazonaws.com/)
+
+## Contributing
+
+We welcome improvements and fixes from the wider community! To report bugs within this package, please create an issue in this repository.
+
+Please read our [contribution guidelines](../../CONTRIBUTING.md) before getting started.
+
+### Install Code and Dependencies
+
+Ensure that you have installed Python >=3.6 and Docker. Then:
+
+```bash
+pip install -e .[dev]
+```
+
+### Test
+
+Tests depend on a running ganache instance with the 0x contracts deployed in it. For convenience, a docker container is provided that has ganache-cli and a snapshot containing the necessary contracts. A shortcut is provided to run that docker container: `./setup.py ganache`. With that running, the tests can be run with `./setup.py test`.
+
+### Clean
+
+`./setup.py clean --all`
+
+### Lint
+
+`./setup.py lint`
+
+### Build Documentation
+
+`./setup.py build_sphinx`
+
+### More
+
+See `./setup.py --help-commands` for more info.