aboutsummaryrefslogtreecommitdiffstats
path: root/guix
diff options
context:
space:
mode:
authorTing-Wei Lan <lantw44@gmail.com>2015-04-16 00:02:07 +0800
committerTing-Wei Lan <lantw44@gmail.com>2015-04-16 00:02:07 +0800
commitdf7ef85a0c00d3cb153d4e3ac15b8998613cc490 (patch)
treee74ca33eb7cc90dd94fe945a724d15ce205ff768 /guix
parent82eacb2d250de3a521fdeff164458ba8d561930d (diff)
downloadcopr-rpm-spec-df7ef85a0c00d3cb153d4e3ac15b8998613cc490.tar
copr-rpm-spec-df7ef85a0c00d3cb153d4e3ac15b8998613cc490.tar.gz
copr-rpm-spec-df7ef85a0c00d3cb153d4e3ac15b8998613cc490.tar.bz2
copr-rpm-spec-df7ef85a0c00d3cb153d4e3ac15b8998613cc490.tar.lz
copr-rpm-spec-df7ef85a0c00d3cb153d4e3ac15b8998613cc490.tar.xz
copr-rpm-spec-df7ef85a0c00d3cb153d4e3ac15b8998613cc490.tar.zst
copr-rpm-spec-df7ef85a0c00d3cb153d4e3ac15b8998613cc490.zip
guix: Fix installation problem with DNF
It seems someone hit this problem several months ago ... http://corecompute.com/fedora/fedora_20150118.html
Diffstat (limited to 'guix')
-rw-r--r--guix/guix/guix.spec14
1 files changed, 9 insertions, 5 deletions
diff --git a/guix/guix/guix.spec b/guix/guix/guix.spec
index c16e606..d557ee0 100644
--- a/guix/guix/guix.spec
+++ b/guix/guix/guix.spec
@@ -1,6 +1,6 @@
Name: guix
Version: 0.8.1
-Release: 2%{?dist}
+Release: 3%{?dist}
Summary: a purely functional package manager for the GNU system
Group: System Environment/Base
@@ -25,8 +25,8 @@ BuildRequires: systemd
Requires: guile >= %{guile_required}
Requires: sqlite >= %{sqlite_required}
Requires: bzip2, libgcrypt
-Requires(post): /sbin/useradd
-Requires(post): /sbin/groupadd
+Requires(post): /usr/sbin/useradd
+Requires(post): /usr/sbin/groupadd
Requires(post): /usr/bin/gpasswd
Requires(post): /sbin/install-info
Requires(preun): /sbin/install-info
@@ -78,8 +78,8 @@ install -m 644 %{SOURCE1} %{buildroot}%{_unitdir}/guix.service
%post
/sbin/install-info %{_infodir}/guix.info.gz %{_infodir}/dir || :
if [ "$1" = 1 ]; then
- /sbin/groupadd -r %{guix_group}
- /sbin/useradd -M -N -g %{guix_group} -d /gnu/store -s /sbin/nologin \
+ /usr/sbin/groupadd -r %{guix_group}
+ /usr/sbin/useradd -M -N -g %{guix_group} -d /gnu/store -s /sbin/nologin \
-c "Guix build user" %{guix_user}
/usr/bin/gpasswd -a %{guix_user} %{guix_group} >/dev/null
fi
@@ -175,6 +175,10 @@ fi
%{_emacs_sitelispdir}/guix*.el
%changelog
+* Wed Apr 15 2015 Ting-Wei Lan <lantw44@gmail.com> - 0.8.1-3
+- Use /usr/sbin/useradd and /usr/sbin/groupadd instead of /sbin/useradd and
+ /sbin/groupadd to make this package work with DNF
+
* Fri Mar 20 2015 Ting-Wei Lan <lantw44@gmail.com> - 0.8.1-2
- Rebuilt for Fedora 22 and 23
- Add epoch to guile dependency to prevent it from using compat-guile18