aboutsummaryrefslogtreecommitdiffstats
path: root/guix
diff options
context:
space:
mode:
authorTing-Wei Lan <lantw44@gmail.com>2015-11-22 21:12:49 +0800
committerTing-Wei Lan <lantw44@gmail.com>2015-11-22 21:16:54 +0800
commit131f28b10d14166d97cafd61faf7db3b2d3d40e1 (patch)
treed410293198beafcbeb83349719d3dffdef6bcee7 /guix
parent89cc580288e93680c267acf416a541e64ef59ed7 (diff)
downloadcopr-rpm-spec-131f28b10d14166d97cafd61faf7db3b2d3d40e1.tar
copr-rpm-spec-131f28b10d14166d97cafd61faf7db3b2d3d40e1.tar.gz
copr-rpm-spec-131f28b10d14166d97cafd61faf7db3b2d3d40e1.tar.bz2
copr-rpm-spec-131f28b10d14166d97cafd61faf7db3b2d3d40e1.tar.lz
copr-rpm-spec-131f28b10d14166d97cafd61faf7db3b2d3d40e1.tar.xz
copr-rpm-spec-131f28b10d14166d97cafd61faf7db3b2d3d40e1.tar.zst
copr-rpm-spec-131f28b10d14166d97cafd61faf7db3b2d3d40e1.zip
guix: Guix 0.8.3 -> 0.9.0
Guix build dependencies: guix -+-- guile-json (copr) +-- gnutls-guile (official) +-- emacs (official) +-- emacs-geiser (copr) +-- emacs-magit (copr) --- emacs-dash (copr) emacs-magit package is based on the official (outdated) Fedora package.
Diffstat (limited to 'guix')
-rw-r--r--guix/emacs-dash/emacs-dash.spec64
-rw-r--r--guix/emacs-geiser/emacs-geiser.spec22
-rw-r--r--guix/emacs-magit/emacs-magit.spec140
-rw-r--r--guix/guile-json/guile-json.spec55
-rw-r--r--guix/guix/guix.spec56
5 files changed, 314 insertions, 23 deletions
diff --git a/guix/emacs-dash/emacs-dash.spec b/guix/emacs-dash/emacs-dash.spec
new file mode 100644
index 0000000..1015179
--- /dev/null
+++ b/guix/emacs-dash/emacs-dash.spec
@@ -0,0 +1,64 @@
+%global pkg dash
+%global pkgname Dash
+
+Name: emacs-%{pkg}
+Version: 2.12.1
+Release: 1%{?dist}
+Summary: Dash is a modern list library for Emacs
+
+Group: Applications/Editors
+License: GPLv3+
+URL: https://github.com/magnars/dash.el
+Source0: https://github.com/magnars/dash.el/archive/%{version}.tar.gz
+
+BuildArch: noarch
+BuildRequires: emacs, texinfo
+Requires: emacs(bin) >= %{_emacs_version}
+
+%description
+%{pkgname} is an add-on package for GNU Emacs. It is a modern list library for
+Emacs. No cl required.
+
+
+%prep
+%setup -q -n dash.el-%{version}
+
+
+%build
+./create-docs.sh
+
+
+%install
+mkdir -p %{buildroot}%{_emacs_sitelispdir}
+install -m 755 -d %{buildroot}%{_emacs_sitelispdir}/dash
+install -m 644 dash.el dash-functional.el \
+ %{buildroot}%{_emacs_sitelispdir}/dash/
+%{_emacs_bytecompile} %{buildroot}%{_emacs_sitelispdir}/dash/dash*.el
+mkdir -p %{buildroot}%{_infodir}
+gzip -9 < dash.info > %{buildroot}%{_infodir}/dash.info.gz
+
+
+%post
+/sbin/install-info %{_infodir}/dash.info.gz %{_infodir}/dir || :
+
+
+%preun
+if [ "$1" = 0 ]; then
+ /sbin/install-info --del %{_infodir}/dash.info.gz %{_infodir}/dir || :
+fi
+
+
+%files
+%doc README.md
+%dir %{_emacs_sitelispdir}/dash
+%{_emacs_sitelispdir}/dash/dash.el
+%{_emacs_sitelispdir}/dash/dash.elc
+%{_emacs_sitelispdir}/dash/dash-functional.el
+%{_emacs_sitelispdir}/dash/dash-functional.elc
+%{_infodir}/dash.info.gz
+
+
+
+%changelog
+* Sat Nov 21 2015 Ting-Wei Lan <lantw44@gmail.com> - 2.12.1-1
+- Initial packaging
diff --git a/guix/emacs-geiser/emacs-geiser.spec b/guix/emacs-geiser/emacs-geiser.spec
index eb147ab..9a9a87b 100644
--- a/guix/emacs-geiser/emacs-geiser.spec
+++ b/guix/emacs-geiser/emacs-geiser.spec
@@ -2,10 +2,11 @@
%global pkgname Geiser
Name: emacs-%{pkg}
-Version: 0.7
-Release: 3%{?dist}
+Version: 0.8.1
+Release: 1%{?dist}
Summary: Geiser is an Emacs environment to hack and have fun in Scheme
+Group: Applications/Editors
License: BSD
URL: http://nongnu.org/geiser
Source0: http://download.sv.gnu.org/releases/geiser/%{version}/%{pkg}-%{version}.tar.gz
@@ -30,7 +31,7 @@ keep the Lisp Machine Spirit alive.
%build
-%configure
+%configure --with-lispdir=%{_emacs_sitelispdir}/geiser
make %{?_smp_mflags}
@@ -50,19 +51,24 @@ fi
%files
%license COPYING
-%doc AUTHORS ChangeLog NEWS README THANKS
+%doc AUTHORS ChangeLog NEWS README README.elpa THANKS
%{_bindir}/geiser-racket
%{_infodir}/geiser.info.gz
%{_datadir}/geiser/
-%{_emacs_sitelispdir}/geiser.el
-%{_emacs_sitelispdir}/geiser.elc
-%{_emacs_sitelispdir}/geiser-*.el
-%{_emacs_sitelispdir}/geiser-*.elc
+%dir %{_emacs_sitelispdir}/geiser
+%{_emacs_sitelispdir}/geiser/geiser.el
+%{_emacs_sitelispdir}/geiser/geiser.elc
+%{_emacs_sitelispdir}/geiser/geiser-*.el
+%{_emacs_sitelispdir}/geiser/geiser-*.elc
%exclude %{_infodir}/dir
%changelog
+* Thu Nov 05 2015 Ting-Wei Lan <lantw44@gmail.com> - 0.8.1-1
+- Update to 0.8.1
+- Don't clutter the system site-lisp directory
+
* Sat Oct 10 2015 Ting-Wei Lan <lantw44@gmail.com> - 0.7-3
- Add the missing emacs(bin) Requires
- Use info instead of /sbin/install-info in Requires
diff --git a/guix/emacs-magit/emacs-magit.spec b/guix/emacs-magit/emacs-magit.spec
new file mode 100644
index 0000000..a6c241a
--- /dev/null
+++ b/guix/emacs-magit/emacs-magit.spec
@@ -0,0 +1,140 @@
+%define pkg magit
+%define pkgname Magit
+
+%if %($(pkg-config emacs) ; echo $?)
+%define emacs_version 22.1
+%define emacs_lispdir %{_datadir}/emacs/site-lisp
+%define emacs_startdir %{_datadir}/emacs/site-lisp/site-start.d
+%else
+%define emacs_version %(pkg-config emacs --modversion)
+%define emacs_lispdir %(pkg-config emacs --variable sitepkglispdir)
+%define emacs_startdir %(pkg-config emacs --variable sitestartdir)
+%endif
+
+Name: emacs-%{pkg}
+Version: 2.3.1
+Release: 1%{?dist}
+Summary: Emacs interface to the most common Git operations
+
+Group: Applications/Editors
+License: GPLv3+ and GFDL+
+URL: http://magit.vc
+
+Source0: https://github.com/magit/magit/releases/download/%{version}/magit-%{version}.tar.gz
+
+BuildArch: noarch
+BuildRequires: emacs, emacs-dash, git-core, texinfo
+Requires: emacs(bin) >= %{emacs_version}
+Requires: emacs-dash
+
+Obsoletes: emacs-%{pkg}-el < 2.3.1-1
+Provides: emacs-%{pkg}-el < 2.3.1-1
+
+%description
+%{pkgname} is an add-on package for GNU Emacs. It is an interface to
+the Git source-code management system that aims to make the most
+common operations convenient.
+
+%prep
+%setup -q -n magit-%{version}
+
+%build
+make \
+ MAKEINFO='makeinfo --no-split' \
+ LOAD_PATH='-L %{emacs_lispdir}/dash -L %{_builddir}/magit-%{version}/lisp -L .'
+
+%install
+%make_install \
+ PREFIX=%{_prefix} docdir=%{_pkgdocdir} \
+ LOAD_PATH='-L %{emacs_lispdir}/dash -L %{_builddir}/magit-%{version}/lisp -L .'
+
+# clean up after magit's installer's assumptions
+mkdir -p $RPM_BUILD_ROOT%{emacs_startdir}
+mv $RPM_BUILD_ROOT%{emacs_lispdir}/magit/magit-autoloads.el \
+ $RPM_BUILD_ROOT%{emacs_startdir}/emacs-magit-mode.el
+gzip -9 $RPM_BUILD_ROOT%{_infodir}/magit.info
+gzip -9 $RPM_BUILD_ROOT%{_infodir}/magit-popup.info
+gzip -9 $RPM_BUILD_ROOT%{_infodir}/with-editor.info
+
+
+%post
+/sbin/install-info /usr/share/info/magit.info.gz /usr/share/info/dir
+/sbin/install-info /usr/share/info/magit-popup.info.gz /usr/share/info/dir
+/sbin/install-info /usr/share/info/with-editor.info.gz /usr/share/info/dir
+
+
+%preun
+if [ "$1" = 0 ]; then
+ /sbin/install-info --delete /usr/share/info/magit.info.gz /usr/share/info/dir
+ /sbin/install-info --delete /usr/share/info/magit-popup.info.gz /usr/share/info/dir
+ /sbin/install-info --delete /usr/share/info/with-editor.info.gz /usr/share/info/dir
+fi
+
+
+%files
+%license COPYING
+%doc README.md
+%{emacs_lispdir}/%{pkg}/*.el
+%{emacs_lispdir}/%{pkg}/*.elc
+%{emacs_startdir}/emacs-magit-mode.el
+%{_infodir}/magit.info.gz
+%{_infodir}/magit-popup.info.gz
+%{_infodir}/with-editor.info.gz
+%dir %{emacs_lispdir}/%{pkg}
+%{_pkgdocdir}/AUTHORS.md
+
+
+%changelog
+* Sat Nov 21 2015 Ting-Wei Lan <lantw44@gmail.com> - 2.3.1-1
+- Update to upstream version 2.3.1
+
+* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.2-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
+
+* Sun Jan 4 2015 Jens Petersen <petersen@redhat.com> - 1.2.2-1
+- update to 1.2.2 which works with emacs-24.4 (#1172690)
+
+* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0-4
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
+
+* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0-3
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
+
+* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
+
+* Thu Jan 10 2013 Tom Moertel <tom@moertel.com> - 1.2.0-1
+- Update to upstream version 1.2.0
+
+* Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.1-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
+
+* Wed Jan 25 2012 Tom Moertel <tom@moertel.com> - 1.1.1-1
+- Update to upstream 1.1.1
+
+* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.0-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
+
+* Fri May 13 2011 Tom Moertel <tom@moertel.com> - 1.0.0-1
+- Updated to upstream 1.0.0
+
+* Wed Aug 4 2010 Tom Moertel <tom@moertel.com> - 0.8.2-1
+- Updated to upstream 0.8.2
+
+* Wed Aug 26 2009 Tom Moertel <tom@moertel.com> - 0.7-6
+- Updated for Magit 0.7 final release (note: upstream removed FDL from tarball)
+
+* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7-5.20090122git
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
+
+* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7-4.20090122git
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
+
+* Thu Jan 29 2009 <tom@moertel.com> - 0.7-3.20090122git
+- Added missing build dependency: texinfo
+
+* Tue Jan 27 2009 <tom@moertel.com> - 0.7-2.20090122git
+- Made fixes per Fedora packaging review (thanks Jerry James)
+
+* Fri Jan 23 2009 <tom@moertel.com> - 0.7-1.20090122git
+- Initial packaging.
diff --git a/guix/guile-json/guile-json.spec b/guix/guile-json/guile-json.spec
new file mode 100644
index 0000000..f154a77
--- /dev/null
+++ b/guix/guile-json/guile-json.spec
@@ -0,0 +1,55 @@
+Name: guile-json
+Version: 0.4.0
+Release: 1%{?dist}
+Summary: JSON module for Guile
+
+License: LGPLv3+
+URL: https://savannah.nongnu.org/projects/guile-json
+Source0: http://download.savannah.gnu.org/releases/%{name}/%{name}-%{version}.tar.gz
+
+BuildArch: noarch
+BuildRequires: guile
+Requires: guile
+
+%description
+guile-json is a JSON module for Guile. It supports parsing and building JSON
+documents according to the http://json.org specification. These are the main
+features:
+
+- Strictly complies to http://json.org specification.
+- Build JSON documents programmatically via macros.
+- Unicode support for strings.
+- Allows JSON pretty printing.
+
+
+%prep
+%setup -q
+
+
+%build
+%configure
+make %{?_smp_mflags}
+
+
+%install
+%make_install
+
+
+%files
+%license COPYING COPYING.LESSER
+%doc AUTHORS ChangeLog NEWS README
+%{_datadir}/guile/site/json.scm
+%{_datadir}/guile/site/json.go
+%dir %{_datadir}/guile/site/json
+%{_datadir}/guile/site/json/builder.go
+%{_datadir}/guile/site/json/builder.scm
+%{_datadir}/guile/site/json/parser.go
+%{_datadir}/guile/site/json/parser.scm
+%{_datadir}/guile/site/json/syntax.go
+%{_datadir}/guile/site/json/syntax.scm
+
+
+
+%changelog
+* Sat Nov 21 2015 Ting-Wei Lan <lantw44@gmail.com> - 0.4.0-1
+- Initial packaging
diff --git a/guix/guix/guix.spec b/guix/guix/guix.spec
index f859f71..da24b15 100644
--- a/guix/guix/guix.spec
+++ b/guix/guix/guix.spec
@@ -1,6 +1,6 @@
Name: guix
-Version: 0.8.3
-Release: 2%{?dist}
+Version: 0.9.0
+Release: 1%{?dist}
Summary: A purely functional package manager for the GNU system
License: GPLv3+
@@ -14,10 +14,12 @@ Source0: ftp://alpha.gnu.org/gnu/%{name}/%{name}-%{version}.tar.gz
BuildRequires: pkgconfig(guile-2.0)
BuildRequires: pkgconfig(sqlite3)
BuildRequires: bzip2-devel, libgcrypt-devel, gettext
-BuildRequires: emacs, emacs-geiser, bash-completion
+BuildRequires: emacs, emacs-geiser, emacs-magit, bash-completion
+BuildRequires: guile-json, gnutls-guile
BuildRequires: systemd
Requires: gzip, bzip2, xz
+Requires: /usr/lib64/libgcrypt.so
Requires: emacs-filesystem >= %{_emacs_version}
Requires(post): /usr/sbin/useradd
Requires(post): /usr/sbin/usermod
@@ -30,6 +32,9 @@ Requires(preun): info
Requires(preun): systemd
Requires(postun): systemd
+Recommends: guile-json, gnutls-guile
+Suggests: emacs, emacs-geiser, emacs-magit
+
Obsoletes: %{name}-emacs <= 0.8.3-1
Obsoletes: %{name}-emacs-el <= 0.8.3-1
Provides: %{name}-emacs <= 0.8.3-1
@@ -49,24 +54,31 @@ composed.
%build
-%configure --disable-rpath --with-bash-completion-dir=%{completionsdir}
+%configure --disable-rpath \
+ --with-bash-completion-dir=%{completionsdir} \
+ --with-lispdir=%{_emacs_sitelispdir}/guix
make %{?_smp_mflags}
%check
-# Remove the check that don't work because of depending on external resources
-sed -i 's|tests/builders.scm||' Makefile
-# Using user namespaces in mock is not allowed
-sed -i 's|tests/syscalls.scm||' Makefile
-sed -i 's|tests/containers.scm||' Makefile
-# I don't know why this fails on my machine
-sed -i 's|tests/guix-package-net.sh||' Makefile
+# guix-environment-container.sh doesn't work on tmpfs
+if [ "`stat -c %%T -f`" = "tmpfs" ]; then
+ sed -i 's|tests/guix-environment-container.sh||' Makefile
+fi
+
+# user namespace is not supported in chroot
+if unshare -Ur true; then :; else
+ sed -i 's|tests/syscalls.scm||' Makefile
+ sed -i 's|tests/containers.scm||' Makefile
+ sed -i 's|tests/guix-environment-container.sh||' Makefile
+fi
+
make %{?_smp_mflags} check
%install
make install DESTDIR=%{buildroot} systemdservicedir=%{_unitdir}
-%{_emacs_bytecompile} %{buildroot}%{_emacs_sitelispdir}/guix*.el
+%{_emacs_bytecompile} %{buildroot}%{_emacs_sitelispdir}/guix/guix*.el
%find_lang guix
%find_lang guix-packages
@@ -75,7 +87,7 @@ make install DESTDIR=%{buildroot} systemdservicedir=%{_unitdir}
/sbin/install-info %{_infodir}/%{name}.info.gz %{_infodir}/dir || :
if [ "$1" = 1 ]; then
/usr/sbin/groupadd -r %{guix_group}
- /usr/sbin/useradd -M -N -g %{guix_group} -d /gnu/store -s /sbin/nologin \
+ /usr/sbin/useradd -r -M -N -g %{guix_group} -d /gnu/store -s /sbin/nologin \
-c "Guix build user" %{guix_user}
/usr/bin/gpasswd -a %{guix_user} %{guix_group} >/dev/null
elif [ "$1" -gt 1 ]; then
@@ -180,6 +192,9 @@ fi
%dir %{_datadir}/guile/site/2.0/guix/scripts
%{_datadir}/guile/site/2.0/guix/scripts/*.scm
%{_datadir}/guile/site/2.0/guix/scripts/*.go
+%dir %{_datadir}/guile/site/2.0/guix/scripts/container
+%{_datadir}/guile/site/2.0/guix/scripts/container/*.scm
+%{_datadir}/guile/site/2.0/guix/scripts/container/*.go
%dir %{_datadir}/guile/site/2.0/guix/scripts/import
%{_datadir}/guile/site/2.0/guix/scripts/import/*.scm
%{_datadir}/guile/site/2.0/guix/scripts/import/*.go
@@ -188,10 +203,15 @@ fi
%{_datadir}/guile/site/2.0/guix/build-system/*.go
%{_infodir}/%{name}.info*
%{_infodir}/images/bootstrap-graph.png.gz
+%{_infodir}/images/coreutils-bag-graph.png.gz
+%{_infodir}/images/coreutils-graph.png.gz
%{_infodir}/images/coreutils-size-map.png.gz
+%{_infodir}/images/dmd-graph.png.gz
+%{_infodir}/images/service-graph.png.gz
%exclude %{_infodir}/dir
%{_mandir}/man1/guix-archive.1*
%{_mandir}/man1/guix-build.1*
+%{_mandir}/man1/guix-challenge.1*
%{_mandir}/man1/guix-daemon.1*
%{_mandir}/man1/guix-download.1*
%{_mandir}/man1/guix-edit.1*
@@ -208,13 +228,19 @@ fi
%{_mandir}/man1/guix-system.1*
%{_mandir}/man1/guix.1*
%{completionsdir}/guix
-%{_emacs_sitelispdir}/guix*.elc
-%{_emacs_sitelispdir}/guix*.el
+%dir %{_emacs_sitelispdir}/guix
+%{_emacs_sitelispdir}/guix/guix*.elc
+%{_emacs_sitelispdir}/guix/guix*.el
%{_unitdir}/guix-daemon.service
%changelog
+* Sun Nov 22 2015 Ting-Wei Lan <lantw44@gmail.com> - 0.9.0-1
+- Update to 0.9.0
+- Don't clutter the system site-lisp directory
+- The build user of guix-daemon should be a system account
+
* Sat Oct 10 2015 Ting-Wei Lan <lantw44@gmail.com> - 0.8.3-2
- Remove group tag, which is not required
- Use pkgconfig in BuildRequires