aboutsummaryrefslogtreecommitdiffstats
path: root/guix/guile-ssh
diff options
context:
space:
mode:
authorTing-Wei Lan <lantw44@gmail.com>2024-11-02 23:33:37 +0800
committerTing-Wei Lan <lantw44@gmail.com>2024-11-02 23:33:37 +0800
commit4989e276e3322baf9a726fd959aa2f36f4c894f0 (patch)
tree57d6bf1251835e96e93bb1b259e42163718d45b6 /guix/guile-ssh
parent8d76fa0de55af633bcdbe6e6ca3c1bef24eec78b (diff)
downloadcopr-rpm-spec-4989e276e3322baf9a726fd959aa2f36f4c894f0.tar
copr-rpm-spec-4989e276e3322baf9a726fd959aa2f36f4c894f0.tar.gz
copr-rpm-spec-4989e276e3322baf9a726fd959aa2f36f4c894f0.tar.bz2
copr-rpm-spec-4989e276e3322baf9a726fd959aa2f36f4c894f0.tar.lz
copr-rpm-spec-4989e276e3322baf9a726fd959aa2f36f4c894f0.tar.xz
copr-rpm-spec-4989e276e3322baf9a726fd959aa2f36f4c894f0.tar.zst
copr-rpm-spec-4989e276e3322baf9a726fd959aa2f36f4c894f0.zip
guix: guile-ssh 0.16.3 -> 0.17.0
Diffstat (limited to 'guix/guile-ssh')
-rw-r--r--guix/guile-ssh/guile-ssh-0.17.0-bool.patch30
-rw-r--r--guix/guile-ssh/guile-ssh-0.17.0-dsa-1.patch51
-rw-r--r--guix/guile-ssh/guile-ssh-0.17.0-dsa-2.patch57
-rw-r--r--guix/guile-ssh/guile-ssh-0.17.0-dsa-3.patch44
-rw-r--r--guix/guile-ssh/guile-ssh-0.17.0-dsa-4.patch33
-rw-r--r--guix/guile-ssh/guile-ssh.spec11
6 files changed, 225 insertions, 1 deletions
diff --git a/guix/guile-ssh/guile-ssh-0.17.0-bool.patch b/guix/guile-ssh/guile-ssh-0.17.0-bool.patch
new file mode 100644
index 0000000..b976df1
--- /dev/null
+++ b/guix/guile-ssh/guile-ssh-0.17.0-bool.patch
@@ -0,0 +1,30 @@
+From 30fc103c67f3bf6cd30b17379ba966b260cfa534 Mon Sep 17 00:00:00 2001
+From: Peter Tillemans <pti@snamellit.com>
+Date: Wed, 18 Sep 2024 15:52:46 +0200
+Subject: [PATCH] fix compile error caused by bool identifier
+
+confusion of variable name with typename is now an error.
+---
+ libguile-ssh/session-func.c | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/libguile-ssh/session-func.c b/libguile-ssh/session-func.c
+index 7006b62..836cd27 100644
+--- a/libguile-ssh/session-func.c
++++ b/libguile-ssh/session-func.c
+@@ -234,12 +234,12 @@ set_int32_opt (ssh_session session, int type, SCM value)
+ static inline int
+ set_bool_opt (ssh_session session, int type, SCM value)
+ {
+- int32_t bool;
++ int32_t bool_value;
+
+ SCM_ASSERT (scm_is_bool (value), value, SCM_ARG3, "session-set!");
+
+- bool = scm_to_bool (value);
+- return ssh_options_set (session, type, &bool);
++ bool_value = scm_to_bool (value);
++ return ssh_options_set (session, type, &bool_value);
+ }
+
+ /* Convert VALUE to a socket file descriptor and pass it to
diff --git a/guix/guile-ssh/guile-ssh-0.17.0-dsa-1.patch b/guix/guile-ssh/guile-ssh-0.17.0-dsa-1.patch
new file mode 100644
index 0000000..6493600
--- /dev/null
+++ b/guix/guile-ssh/guile-ssh-0.17.0-dsa-1.patch
@@ -0,0 +1,51 @@
+From 9d0c7c2bb10b1b2cc02de1540a830f5756e6495d Mon Sep 17 00:00:00 2001
+From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
+Date: Wed, 18 Sep 2024 22:02:53 +0300
+Subject: [PATCH] tests/server ("make-server", "server-get"): Fix
+
+* tests/server.scm ("make-server", "server-get"): Don't try to use DSA key
+when it is disabled.
+---
+ tests/server.scm | 10 ++++++----
+ 1 file changed, 6 insertions(+), 4 deletions(-)
+
+diff --git a/tests/server.scm b/tests/server.scm
+index f24a9d2..2e4ee3e 100644
+--- a/tests/server.scm
++++ b/tests/server.scm
+@@ -1,6 +1,6 @@
+ ;;; server.scm -- Testing of server procedures without a client.
+
+-;; Copyright (C) 2014, 2015, 2016 Artyom V. Poptsov <poptsov.artyom@gmail.com>
++;; Copyright (C) 2014, 2015, 2016, 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
+ ;;
+ ;; This file is a part of Guile-SSH.
+ ;;
+@@ -127,7 +127,7 @@
+ (make-server #:bindaddr "127.0.0.1"
+ #:bindport 123456
+ #:rsakey %rsakey
+- #:dsakey %dsakey
++ #:dsakey (and (dsa-support?) %dsakey)
+ #:banner "banner"
+ #:log-verbosity 'nolog
+ #:blocking-mode #f)))
+@@ -142,14 +142,16 @@
+ (server (make-server #:bindaddr bindaddr
+ #:bindport bindport
+ #:rsakey %rsakey
+- #:dsakey %dsakey
++ #:dsakey (and (dsa-support?) %dsakey)
+ #:banner banner
+ #:log-verbosity log-verbosity
+ #:blocking-mode blocking-mode)))
+ (and (eq? (server-get server 'bindaddr) bindaddr)
+ (eq? (server-get server 'bindport) bindport)
+ (eq? (server-get server 'rsakey) %rsakey)
+- (eq? (server-get server 'dsakey) %dsakey)
++ (if (dsa-support?)
++ (eq? (server-get server 'dsakey) %dsakey)
++ #t)
+ (eq? (server-get server 'banner) banner)
+ (eq? (server-get server 'log-verbosity) log-verbosity)
+ (eq? (server-get server 'blocking-mode) blocking-mode))))
diff --git a/guix/guile-ssh/guile-ssh-0.17.0-dsa-2.patch b/guix/guile-ssh/guile-ssh-0.17.0-dsa-2.patch
new file mode 100644
index 0000000..4446a53
--- /dev/null
+++ b/guix/guile-ssh/guile-ssh-0.17.0-dsa-2.patch
@@ -0,0 +1,57 @@
+From c358cf9a050ae62c62969628b633a413ba02fe56 Mon Sep 17 00:00:00 2001
+From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
+Date: Tue, 24 Sep 2024 20:09:09 +0300
+Subject: [PATCH] tests/common.scm: Don't use DSA keys when DSA is not
+ supported
+
+* tests/common.scm: Don't use DSA keys when DSA is not supported.
+* tests/common/test-server.scm: Likewise.
+---
+ tests/common.scm | 3 ++-
+ tests/common/test-server.scm | 5 +++--
+ 2 files changed, 5 insertions(+), 3 deletions(-)
+
+diff --git a/tests/common.scm b/tests/common.scm
+index 2bd275a..ffc3f1a 100644
+--- a/tests/common.scm
++++ b/tests/common.scm
+@@ -31,6 +31,7 @@
+ #:use-module (ssh auth)
+ #:use-module (ssh log)
+ #:use-module (ssh message)
++ #:use-module (ssh version)
+ #:export (;; Variables
+ %topdir
+ %topbuilddir
+@@ -263,7 +264,7 @@
+ #:bindaddr %addr
+ #:bindport *port*
+ #:rsakey %rsakey
+- #:dsakey %dsakey
++ #:dsakey (and (dsa-support?) %dsakey)
+ #:log-verbosity 'functions)))
+ (format-log/scm 'nolog "make-server-for-test"
+ "***** bindaddr: ~a; bindport: ~a" %addr *port*)
+diff --git a/tests/common/test-server.scm b/tests/common/test-server.scm
+index a9e2491..8314aa7 100755
+--- a/tests/common/test-server.scm
++++ b/tests/common/test-server.scm
+@@ -10,7 +10,8 @@
+ (ssh session)
+ (ssh tunnel)
+ (ssh log)
+- (ssh server))
++ (ssh server)
++ (ssh version))
+
+
+ (define (main args)
+@@ -41,7 +42,7 @@
+ #:bindaddr %addr
+ #:bindport port
+ #:rsakey %rsakey
+- #:dsakey %dsakey
++ #:dsakey (and (dsa-support?) %dsakey)
+ #:log-verbosity 'functions)))
+ (server-listen s)
+ (let ((p (open-output-file (format #f
diff --git a/guix/guile-ssh/guile-ssh-0.17.0-dsa-3.patch b/guix/guile-ssh/guile-ssh-0.17.0-dsa-3.patch
new file mode 100644
index 0000000..3cbf855
--- /dev/null
+++ b/guix/guile-ssh/guile-ssh-0.17.0-dsa-3.patch
@@ -0,0 +1,44 @@
+From bbff63f86513d43c70649ad3d2adc57254e821cd Mon Sep 17 00:00:00 2001
+From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
+Date: Tue, 24 Sep 2024 20:13:23 +0300
+Subject: [PATCH] examples/ssshd.scm.in (main): Bugfix: Handle deprecation of
+ DSA
+
+* examples/ssshd.scm.in (main): Bugfix: Don't try to use DSA keys when DSA is
+not supported.
+---
+ examples/ssshd.scm.in | 7 ++++---
+ 1 file changed, 4 insertions(+), 3 deletions(-)
+
+diff --git a/examples/ssshd.scm.in b/examples/ssshd.scm.in
+index 143317c..b7bfbc9 100644
+--- a/examples/ssshd.scm.in
++++ b/examples/ssshd.scm.in
+@@ -5,7 +5,7 @@
+
+ ;;; ssshd.scm -- Scheme Secure Shell Daemon.
+
+-;; Copyright (C) 2013-2021 Artyom V. Poptsov <poptsov.artyom@gmail.com>
++;; Copyright (C) 2013-2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
+ ;;
+ ;; This program is free software: you can redistribute it and/or
+ ;; modify it under the terms of the GNU General Public License as
+@@ -38,7 +38,8 @@
+ (ssh session)
+ (ssh channel)
+ (ssh key)
+- (ssh auth)) ; userauth-*
++ (ssh auth) ; userauth-*
++ (ssh version))
+
+
+ ;;; Variables and constants
+@@ -280,7 +281,7 @@ Options:
+
+ (let ((server (make-server #:bindport bindport
+ #:rsakey rsakey
+- #:dsakey dsakey
++ #:dsakey (and (dsa-support?) dsakey)
+ #:log-verbosity (string->symbol ssh-debug)
+ #:banner "Scheme Secure Shell Daemon"))
+ (channel #f))
diff --git a/guix/guile-ssh/guile-ssh-0.17.0-dsa-4.patch b/guix/guile-ssh/guile-ssh-0.17.0-dsa-4.patch
new file mode 100644
index 0000000..fc7f71a
--- /dev/null
+++ b/guix/guile-ssh/guile-ssh-0.17.0-dsa-4.patch
@@ -0,0 +1,33 @@
+From c1359506ee6cfb1ea2538d96d125cdf8b7c2bb53 Mon Sep 17 00:00:00 2001
+From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
+Date: Tue, 24 Sep 2024 20:15:39 +0300
+Subject: [PATCH] tests/key.scm: Bugfix: Handle DSA deprecation properly
+
+* tests/key.scm: Bugfix: Don't try to load a DSA key when DSA is not
+supported.
+---
+ tests/key.scm | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/tests/key.scm b/tests/key.scm
+index c1d073c..d844854 100644
+--- a/tests/key.scm
++++ b/tests/key.scm
+@@ -1,6 +1,6 @@
+ ;;; key.scm -- Testing of Guile-SSH keys
+
+-;; Copyright (C) 2014-2022 Artyom V. Poptsov <poptsov.artyom@gmail.com>
++;; Copyright (C) 2014-2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
+ ;;
+ ;; This file is a part of Guile-SSH.
+ ;;
+@@ -70,7 +70,8 @@
+ (private-key-from-file %ecdsakey))
+
+ (define *rsa-pub-key* (public-key-from-file %rsakey-pub))
+-(define *dsa-pub-key* (public-key-from-file %dsakey-pub))
++(define *dsa-pub-key* (and (dsa-support?)
++ (public-key-from-file %dsakey-pub)))
+ (define *ecdsa-pub-key* (when-openssl
+ (public-key-from-file %ecdsakey-pub)))
+
diff --git a/guix/guile-ssh/guile-ssh.spec b/guix/guile-ssh/guile-ssh.spec
index 7a84410..ff5abe0 100644
--- a/guix/guile-ssh/guile-ssh.spec
+++ b/guix/guile-ssh/guile-ssh.spec
@@ -1,5 +1,5 @@
Name: guile-ssh
-Version: 0.16.3
+Version: 0.17.0
Release: 1%{?dist}
Summary: A library that provides access to the SSH protocol for GNU Guile
@@ -7,6 +7,12 @@ License: GPLv3+
URL: https://memory-heap.org/~avp/projects/guile-ssh
Source0: https://github.com/artyom-poptsov/guile-ssh/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
+Patch0: guile-ssh-0.17.0-bool.patch
+Patch1: guile-ssh-0.17.0-dsa-1.patch
+Patch2: guile-ssh-0.17.0-dsa-2.patch
+Patch3: guile-ssh-0.17.0-dsa-3.patch
+Patch4: guile-ssh-0.17.0-dsa-4.patch
+
%global guile_source_dir %{_datadir}/guile/site/3.0
%global guile_ccache_dir %{_libdir}/guile/3.0/site-ccache
@@ -74,6 +80,9 @@ fi
%changelog
+* Sat Nov 02 2024 Ting-Wei Lan <lantw44@gmail.com> - 0.17.0-1
+- Update to 0.17.0
+
* Wed Apr 19 2023 Ting-Wei Lan <lantw44@gmail.com> - 0.16.3-1
- Update to 0.16.3