aboutsummaryrefslogtreecommitdiffstats
path: root/guix/emacs-with-editor/emacs-with-editor.spec
diff options
context:
space:
mode:
authorTing-Wei Lan <lantw44@gmail.com>2016-03-04 01:42:59 +0800
committerTing-Wei Lan <lantw44@gmail.com>2016-03-04 01:42:59 +0800
commitfb7623cf959f597b338bf1b5d08a86205c6341ab (patch)
treed06d0ea232205611c82d23800218215a04e109ab /guix/emacs-with-editor/emacs-with-editor.spec
parent6bc20e9f40a8aecd64f0b10d49a6d1b883cedc92 (diff)
downloadcopr-rpm-spec-fb7623cf959f597b338bf1b5d08a86205c6341ab.tar
copr-rpm-spec-fb7623cf959f597b338bf1b5d08a86205c6341ab.tar.gz
copr-rpm-spec-fb7623cf959f597b338bf1b5d08a86205c6341ab.tar.bz2
copr-rpm-spec-fb7623cf959f597b338bf1b5d08a86205c6341ab.tar.lz
copr-rpm-spec-fb7623cf959f597b338bf1b5d08a86205c6341ab.tar.xz
copr-rpm-spec-fb7623cf959f597b338bf1b5d08a86205c6341ab.tar.zst
copr-rpm-spec-fb7623cf959f597b338bf1b5d08a86205c6341ab.zip
guix: emacs-magit 2.3.1 -> 2.5.0
Diffstat (limited to 'guix/emacs-with-editor/emacs-with-editor.spec')
-rw-r--r--guix/emacs-with-editor/emacs-with-editor.spec65
1 files changed, 65 insertions, 0 deletions
diff --git a/guix/emacs-with-editor/emacs-with-editor.spec b/guix/emacs-with-editor/emacs-with-editor.spec
new file mode 100644
index 0000000..dbcd009
--- /dev/null
+++ b/guix/emacs-with-editor/emacs-with-editor.spec
@@ -0,0 +1,65 @@
+%global pkg with-editor
+%global pkgname With-Editor
+
+Name: emacs-%{pkg}
+Version: 2.5.0
+Release: 1%{?dist}
+Summary: Use the Emacsclient as the editor of child processes
+
+Group: Applications/Editors
+License: GPLv3+
+URL: http://magit.vc
+Source0: https://github.com/magit/with-editor/archive/v%{version}.tar.gz
+
+BuildArch: noarch
+BuildRequires: emacs, emacs-dash, texinfo
+Requires: emacs(bin) >= %{_emacs_version}
+Requires: emacs-dash
+
+%description
+%{pkgname} is an add-on package for GNU Emacs. It makes it easy to use the
+Emacsclient as the editor of child processes, making sure they know how to
+call home.
+
+
+%prep
+%setup -q -n with-editor-%{version}
+
+
+%build
+touch dir
+make MAKEINFO='makeinfo --no-split' EFLAGS='-L %{_emacs_sitelispdir}/dash' all
+
+
+%install
+mkdir -p %{buildroot}%{_emacs_sitelispdir}
+install -m 755 -d %{buildroot}%{_emacs_sitelispdir}/with-editor
+install -m 644 with-editor.el \
+ %{buildroot}%{_emacs_sitelispdir}/with-editor/
+%{_emacs_bytecompile} %{buildroot}%{_emacs_sitelispdir}/with-editor/with-editor*.el
+mkdir -p %{buildroot}%{_infodir}
+gzip -9 < with-editor.info > %{buildroot}%{_infodir}/with-editor.info.gz
+
+
+%post
+/sbin/install-info %{_infodir}/with-editor.info.gz %{_infodir}/dir || :
+
+
+%preun
+if [ "$1" = 0 ]; then
+ /sbin/install-info --del %{_infodir}/with-editor.info.gz %{_infodir}/dir || :
+fi
+
+
+%files
+%doc README.md
+%dir %{_emacs_sitelispdir}/with-editor
+%{_emacs_sitelispdir}/with-editor/with-editor.el
+%{_emacs_sitelispdir}/with-editor/with-editor.elc
+%{_infodir}/with-editor.info.gz
+
+
+
+%changelog
+* Fri Mar 04 2016 Ting-Wei Lan <lantw44@gmail.com> - 2.5.0-1
+- Initial packaging