aboutsummaryrefslogtreecommitdiffstats
path: root/guix/emacs-magit-popup
diff options
context:
space:
mode:
authorTing-Wei Lan <lantw44@gmail.com>2018-07-15 22:51:37 +0800
committerTing-Wei Lan <lantw44@gmail.com>2018-07-15 22:51:37 +0800
commitfffa08da592c8f1430af123beeabffde3ddb70c5 (patch)
tree2f71b4511ab0569849c61bcb879f3c6a5b50635d /guix/emacs-magit-popup
parenta45b7c94911b3cab17b64ff682de69d7896a3f27 (diff)
downloadcopr-rpm-spec-fffa08da592c8f1430af123beeabffde3ddb70c5.tar
copr-rpm-spec-fffa08da592c8f1430af123beeabffde3ddb70c5.tar.gz
copr-rpm-spec-fffa08da592c8f1430af123beeabffde3ddb70c5.tar.bz2
copr-rpm-spec-fffa08da592c8f1430af123beeabffde3ddb70c5.tar.lz
copr-rpm-spec-fffa08da592c8f1430af123beeabffde3ddb70c5.tar.xz
copr-rpm-spec-fffa08da592c8f1430af123beeabffde3ddb70c5.tar.zst
copr-rpm-spec-fffa08da592c8f1430af123beeabffde3ddb70c5.zip
guix: emacs-magit-popup 2.12.2 -> 2.12.3
Diffstat (limited to 'guix/emacs-magit-popup')
-rw-r--r--guix/emacs-magit-popup/emacs-magit-popup.spec13
1 files changed, 10 insertions, 3 deletions
diff --git a/guix/emacs-magit-popup/emacs-magit-popup.spec b/guix/emacs-magit-popup/emacs-magit-popup.spec
index 7ebf3c4..4b6d0a4 100644
--- a/guix/emacs-magit-popup/emacs-magit-popup.spec
+++ b/guix/emacs-magit-popup/emacs-magit-popup.spec
@@ -2,7 +2,7 @@
%global pkgname Magit-Popup
Name: emacs-%{pkg}
-Version: 2.12.2
+Version: 2.12.3
Release: 1%{?dist}
Summary: Define prefix-infix-suffix command combos for Emacs
@@ -36,7 +36,9 @@ install -m 755 -d %{buildroot}%{_emacs_sitelispdir}/magit-popup
install -m 644 magit-popup.el magit-popup.elc \
%{buildroot}%{_emacs_sitelispdir}/magit-popup/
install -m 644 magit-popup-autoloads.el \
- %{buildroot}%{_emacs_sitestartdir}/magit-popup.el
+ %{buildroot}%{_emacs_sitelispdir}/magit-popup/
+ln -rs %{buildroot}%{_emacs_sitelispdir}/magit-popup/magit-popup-autoloads.el \
+ %{buildroot}%{_emacs_sitestartdir}
mkdir -p %{buildroot}%{_infodir}
gzip -9 < magit-popup.info > %{buildroot}%{_infodir}/magit-popup.info.gz
@@ -57,11 +59,16 @@ fi
%dir %{_emacs_sitelispdir}/magit-popup
%{_emacs_sitelispdir}/magit-popup/magit-popup.el
%{_emacs_sitelispdir}/magit-popup/magit-popup.elc
-%{_emacs_sitestartdir}/magit-popup.el
+%{_emacs_sitelispdir}/magit-popup/magit-popup-autoloads.el
+%{_emacs_sitestartdir}/magit-popup-autoloads.el
%{_infodir}/magit-popup.info.gz
%changelog
+* Sat Jul 07 2018 Ting-Wei Lan <lantw44@gmail.com> - 2.12.3-1
+- Update to 2.12.3
+- Fix autoloads by creating a symlink instead of moving the script itself
+
* Tue Mar 13 2018 Ting-Wei Lan <lantw44@gmail.com> - 2.12.2-1
- Initial packaging